summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-09-03 01:31:01 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-09-03 11:55:19 +0200
commitb32dd6940856db60153cf8f32c0067b36a59de53 (patch)
treeccc357f59de3ee2287a4bdf4d36fa1a13642c676 /app-text
parentapp-editors/kile: 2.9.91 version bump (3.0 beta1) (diff)
downloadgentoo-b32dd6940856db60153cf8f32c0067b36a59de53.tar.gz
gentoo-b32dd6940856db60153cf8f32c0067b36a59de53.tar.bz2
gentoo-b32dd6940856db60153cf8f32c0067b36a59de53.zip
app-text/enchant: version 1.6.0 → 1.6.1, bug #570030
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-text')
-rw-r--r--app-text/enchant/Manifest1
-rw-r--r--app-text/enchant/enchant-1.6.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-text/enchant/Manifest b/app-text/enchant/Manifest
index 5a6d052e37c4..f9cb48bc0210 100644
--- a/app-text/enchant/Manifest
+++ b/app-text/enchant/Manifest
@@ -1 +1,2 @@
DIST enchant-1.6.0.tar.gz 607018 SHA256 2fac9e7be7e9424b2c5570d8affe568db39f7572c10ed48d4e13cddf03f7097f SHA512 0ca1634bb783df51512df4abecc89abdadee6baf7330d6e5f90cc15d10779896a3521a1c079ecc07e4df4f7a018ce398cca9d0125a7845a314a059840ebc9137 WHIRLPOOL f6677a11f1d05e210cbd6a7b13f3987ea93b3f1e73537b048093c14686b0310e75a89fdb8798ad0ed386a7e1cd793f60820006df8c1f7919c46c7245ee6a74c9
+DIST enchant-1.6.1.tar.gz 642124 SHA256 bef0d9c0fef2e4e8746956b68e4d6c6641f6b85bd2908d91731efb68eba9e3f5 SHA512 26c62dfa89ee40150db502651a2f876fba00569b7015f205dae27a029557effacff335bbe36124dbe6686537da2305bcab02592179d03e95fdf9741d54b98036 WHIRLPOOL daffe1ee16e731d3d6ba56362f882c8f8bd7462a264fcf9caf05ed8093c0ca275977fb9c83c391d9e3287e6e98516b52e468c9bf9cc86532cf0b3eeba8f02fbd
diff --git a/app-text/enchant/enchant-1.6.1.ebuild b/app-text/enchant/enchant-1.6.1.ebuild
new file mode 100644
index 000000000000..ff615eb5b756
--- /dev/null
+++ b/app-text/enchant/enchant-1.6.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit versionator
+
+MY_PV="$(replace_all_version_separators '-')"
+DESCRIPTION="Spellchecker wrapping library"
+HOMEPAGE="https://abiword.github.io/enchant/"
+SRC_URI="https://github.com/AbiWord/enchant/releases/download/${PN}-${MY_PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+IUSE="aspell +hunspell static-libs test zemberek"
+REQUIRED_USE="|| ( hunspell aspell zemberek )"
+
+# FIXME: depends on unittest++ but through pkgconfig which is a Debian hack, bug #629742
+COMMON_DEPENDS="
+ >=dev-libs/glib-2.6:2
+ aspell? ( app-text/aspell )
+ hunspell? ( >=app-text/hunspell-1.2.1:0= )
+ zemberek? ( dev-libs/dbus-glib )
+"
+RDEPEND="${COMMON_DEPENDS}
+ zemberek? ( app-text/zemberek-server )
+"
+DEPEND="${COMMON_DEPENDS}
+ virtual/pkgconfig
+"
+# test? ( dev-libs/unittest++ )
+
+DOCS="AUTHORS BUGS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.0-hunspell150_fix.patch
+)
+
+src_prepare() {
+ default
+ sed -e "/SUBDIRS/ s/unittests//" -i "${S}"/Makefile.{am,in} || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable aspell) \
+ $(use_enable hunspell myspell) \
+ $(use_enable static-libs static) \
+ $(use_enable zemberek) \
+ --disable-hspell \
+ --disable-ispell \
+ --disable-uspell \
+ --disable-voikko \
+ --with-myspell-dir="${EPREFIX}"/usr/share/myspell/
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}