summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/dirdiff
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/dirdiff')
-rw-r--r--app-vim/dirdiff/Manifest2
-rw-r--r--app-vim/dirdiff/dirdiff-1.1.4.ebuild37
-rw-r--r--app-vim/dirdiff/dirdiff-1.1.5.ebuild16
-rw-r--r--app-vim/dirdiff/metadata.xml5
4 files changed, 60 insertions, 0 deletions
diff --git a/app-vim/dirdiff/Manifest b/app-vim/dirdiff/Manifest
new file mode 100644
index 000000000000..ea09469aecf8
--- /dev/null
+++ b/app-vim/dirdiff/Manifest
@@ -0,0 +1,2 @@
+DIST dirdiff-1.1.4.tar.gz 11310 SHA256 f6cec61798477a57ee1e96a5419caa3311c1d11b3c074c3a5bb391668974248d SHA512 d232e658958de1af7b19da38512b9cd566c62f13191c45891128eb8932bfe2a66707dbc9d0dcc8a48363f794c93cb3fa98277611c91577800dd60eb40ef44f5c WHIRLPOOL eca96fa793ebd1364ab19f7082c0812fc097e133691671076a139dd631d07576d7c5b187cdea9f21105f00eb5530e700331292a03eb9e3b64a57e3be189a4f1c
+DIST dirdiff-1.1.5.tar.bz2 11131 SHA256 82b250d37ea973118cd4b146c8ea5e936bf5618a4b78b26d6e4d320c44a678b1 SHA512 d1abc7981d38eb784cec265146fb3b45af32f9df17698d133f6f001608c48d53aa2529f4d3d7204509ee26fcd84e813842b5a8193b145abe9d0cc468f69b7f87 WHIRLPOOL 3da0721c3926bb22f041f199d5be7a8d3e7cc0d2029d929cd9927f403a83feab0e701402cda62a6a3f44adbe0ea091bfd6ac519de4a9a0e1e3e3815a45d6d5c6
diff --git a/app-vim/dirdiff/dirdiff-1.1.4.ebuild b/app-vim/dirdiff/dirdiff-1.1.4.ebuild
new file mode 100644
index 000000000000..a0d968b0c7d3
--- /dev/null
+++ b/app-vim/dirdiff/dirdiff-1.1.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vim-plugin
+
+MY_PN="DirDiff.vim"
+DESCRIPTION="vim plugin: diff and merge two directories recursively"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=102"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="DirDiff.txt"
+
+RDEPEND="sys-apps/diffutils"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc
+ sed -e '0,/" -\*- vim -\*-$/d' -e '/" 0.7 Initial Release$/,9999d' -e 's/^" \?//' \
+ -e 's/\(FILE: \)".\+\.vim"/\1*DirDiff.txt*/' \
+ plugin/DirDiff.vim \
+ > doc/DirDiff.txt
+
+ rm -f README
+}
diff --git a/app-vim/dirdiff/dirdiff-1.1.5.ebuild b/app-vim/dirdiff/dirdiff-1.1.5.ebuild
new file mode 100644
index 000000000000..5bca626077e9
--- /dev/null
+++ b/app-vim/dirdiff/dirdiff-1.1.5.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: diff and merge two directories recursively"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=102"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-apps/diffutils"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
diff --git a/app-vim/dirdiff/metadata.xml b/app-vim/dirdiff/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/dirdiff/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>