summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-24 09:05:20 +0000
committerSam James <sam@gentoo.org>2024-03-24 09:06:11 +0000
commitc7012f128a3c04053924fa1e96ed48a1c758fc65 (patch)
treeb4eba61ca4379fcdfa270b203f430e21aa659e3e /dev-build
parentapp-portage/elt-patches: add 20240324 (diff)
downloadgentoo-c7012f128a3c04053924fa1e96ed48a1c758fc65.tar.gz
gentoo-c7012f128a3c04053924fa1e96ed48a1c758fc65.tar.bz2
gentoo-c7012f128a3c04053924fa1e96ed48a1c758fc65.zip
dev-build/libtool: fix shebang for bash
Always use ${EPREFIX}/bin/bash rather than the current path to bash, so that we work on both usr-merged and non-usr-merged systems. Bug: https://bugs.gentoo.org/927662 Closes: https://bugs.gentoo.org/927650 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/libtool/libtool-2.4.7-r3.ebuild (renamed from dev-build/libtool/libtool-2.4.7-r2.ebuild)2
-rw-r--r--dev-build/libtool/libtool-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/dev-build/libtool/libtool-2.4.7-r2.ebuild b/dev-build/libtool/libtool-2.4.7-r3.ebuild
index 9aeb0ed28993..75bdf19f6d2a 100644
--- a/dev-build/libtool/libtool-2.4.7-r2.ebuild
+++ b/dev-build/libtool/libtool-2.4.7-r3.ebuild
@@ -98,7 +98,7 @@ src_configure() {
# to find a bash shell. if /bin/sh is bash, it uses that. this can
# cause problems for people who switch /bin/sh on the fly to other
# shells, so just force libtool to use /bin/bash all the time.
- export CONFIG_SHELL="$(type -P bash)"
+ export CONFIG_SHELL="${EPREFIX}"/bin/bash
# Do not bother hardcoding the full path to sed.
# Just rely on $PATH. bug #574550
diff --git a/dev-build/libtool/libtool-9999.ebuild b/dev-build/libtool/libtool-9999.ebuild
index e5ecf26e0972..033495d8ee02 100644
--- a/dev-build/libtool/libtool-9999.ebuild
+++ b/dev-build/libtool/libtool-9999.ebuild
@@ -96,7 +96,7 @@ src_configure() {
# to find a bash shell. if /bin/sh is bash, it uses that. this can
# cause problems for people who switch /bin/sh on the fly to other
# shells, so just force libtool to use /bin/bash all the time.
- export CONFIG_SHELL="$(type -P bash)"
+ export CONFIG_SHELL="${EPREFIX}"/bin/bash
# Do not bother hardcoding the full path to sed.
# Just rely on $PATH. bug #574550