summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-cpp/sparsehash
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-cpp/sparsehash')
-rw-r--r--dev-cpp/sparsehash/Manifest2
-rw-r--r--dev-cpp/sparsehash/files/1.10-gcc46.patch16
-rw-r--r--dev-cpp/sparsehash/metadata.xml8
-rw-r--r--dev-cpp/sparsehash/sparsehash-1.10.ebuild28
-rw-r--r--dev-cpp/sparsehash/sparsehash-2.0.2.ebuild22
5 files changed, 76 insertions, 0 deletions
diff --git a/dev-cpp/sparsehash/Manifest b/dev-cpp/sparsehash/Manifest
new file mode 100644
index 000000000000..a2c2234f3840
--- /dev/null
+++ b/dev-cpp/sparsehash/Manifest
@@ -0,0 +1,2 @@
+DIST sparsehash-1.10.tar.gz 289819 SHA256 5a57b77633aab1e59827e51cf6247c4ac521713d45f1764ddba60353cbc9677a SHA512 ecc01e755885b8da5927f4f56c95c02ce9a43e5c0280cdc1cdfa812f787396646925c0f602a35decdf94144e8d2f3ac31b80f5ed98b70ccca607a29bb11f8a35 WHIRLPOOL 643e27499b1981faa7dc8864886c736a5265d78221edaed0fb6bd73eaf943433d5fbe5fe26ec2e52451651e19ce869a6ad08c22d7fb3d71b6cc7bf5866fd3653
+DIST sparsehash-2.0.2.tar.gz 340514 SHA256 2ed639a7155607c097c2029af5f4287296595080b2e5dd2e2ebd9bbb7450b87c SHA512 27d823551bc8364dd3c10f071e51bab55d2bbe9cf74ddb8337d118475aa7fdd38ae07dbb7dbd721c1350830325cadccdadf127f9996f26387e412e108edba3a1 WHIRLPOOL 87d31528bfd7a177c7be3be2bcddf1ba52bcc8791b8b2162cc1902e4cf02695c99b9a6b70fbcfd85d9e03456931bd72fc67b47cad79d0182bd1d4f5eb11e6f0b
diff --git a/dev-cpp/sparsehash/files/1.10-gcc46.patch b/dev-cpp/sparsehash/files/1.10-gcc46.patch
new file mode 100644
index 000000000000..4339b487eca0
--- /dev/null
+++ b/dev-cpp/sparsehash/files/1.10-gcc46.patch
@@ -0,0 +1,16 @@
+ src/google/sparsetable | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/src/google/sparsetable b/src/google/sparsetable
+index 0eeb22e..e8580b9 100644
+--- a/src/google/sparsetable
++++ b/src/google/sparsetable
+@@ -83,6 +83,8 @@
+ #endif
+ #endif
+
++#include <cstddef>
++
+ _START_GOOGLE_NAMESPACE_
+
+ #ifndef HAVE_U_INT16_T
diff --git a/dev-cpp/sparsehash/metadata.xml b/dev-cpp/sparsehash/metadata.xml
new file mode 100644
index 000000000000..a4f851005953
--- /dev/null
+++ b/dev-cpp/sparsehash/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cpp</herd>
+ <upstream>
+ <remote-id type="google-code">google-sparsehash</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/sparsehash/sparsehash-1.10.ebuild b/dev-cpp/sparsehash/sparsehash-1.10.ebuild
new file mode 100644
index 000000000000..7672d800d08e
--- /dev/null
+++ b/dev-cpp/sparsehash/sparsehash-1.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="An extremely memory-efficient hash_map implementation"
+HOMEPAGE="http://code.google.com/p/google-sparsehash/"
+SRC_URI="http://google-sparsehash.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gcc46.patch
+}
+
+src_install() {
+ default
+
+ # Installs just every piece
+ rm -rf "${D}/usr/share/doc"
+ dohtml doc/*
+}
diff --git a/dev-cpp/sparsehash/sparsehash-2.0.2.ebuild b/dev-cpp/sparsehash/sparsehash-2.0.2.ebuild
new file mode 100644
index 000000000000..9e4c4868d84d
--- /dev/null
+++ b/dev-cpp/sparsehash/sparsehash-2.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="An extremely memory-efficient hash_map implementation"
+HOMEPAGE="http://code.google.com/p/sparsehash/"
+SRC_URI="http://sparsehash.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_install() {
+ default
+
+ # Installs just every piece
+ rm -rf "${ED}/usr/share/doc"
+ dohtml doc/*
+}