summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-30 11:38:01 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-30 18:25:12 -0400
commitf25b89664b9da7ead9181135f3b2ba1902d7dbc0 (patch)
treeeafebe8bb1e5e24ef680cd3dcc34be15c0722e64 /dev-cpp/tree
parentapp-misc/g15composer: bump EAPI and drop eutils (diff)
downloadgentoo-f25b89664b9da7ead9181135f3b2ba1902d7dbc0.tar.gz
gentoo-f25b89664b9da7ead9181135f3b2ba1902d7dbc0.tar.bz2
gentoo-f25b89664b9da7ead9181135f3b2ba1902d7dbc0.zip
dev-cpp/tree: drop EAPI=2 ebuild
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-cpp/tree')
-rw-r--r--dev-cpp/tree/Manifest1
-rw-r--r--dev-cpp/tree/tree-2.65-r1.ebuild41
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-cpp/tree/Manifest b/dev-cpp/tree/Manifest
index 967becfe6068..c6030dad7492 100644
--- a/dev-cpp/tree/Manifest
+++ b/dev-cpp/tree/Manifest
@@ -1,2 +1 @@
-DIST tree-2.65.tar.gz 197695 BLAKE2B a2e7e88852f41a5344657da399a25ab9ba8484e72ff0a3a8a550085eb85770060d9691a427979412adf6b5147cb16179bea415aafd9f7758cee996436d03ab5e SHA512 59e8a7052c36082d8dfe848c88fbbc68d2d88ad50426559b218de850bd8953fd7a5142d028785b5c080d4ac67e1c6ff517ad6342365d021b29d4bfa259b9a552
DIST tree-2.81.tar.gz 1167128 BLAKE2B ea92724b16fc7ea8a5f0036f5a7a57d000d66b332b4ba46139463f707f95922f38b1d4d56a6d2fca0a3c4ece8f11e28bbf4aa6bec5c5a7bc59ccaa36a01413d6 SHA512 85e910fdb19ffd03ae79302a95ebffdb44725fd9f291a61d6912f743b54fe9b3d1c863e00c7e75d238f428946809e42c7ae6379b1051688fb06ee6c6d761d294
diff --git a/dev-cpp/tree/tree-2.65-r1.ebuild b/dev-cpp/tree/tree-2.65-r1.ebuild
deleted file mode 100644
index 74cbb2bd2c22..000000000000
--- a/dev-cpp/tree/tree-2.65-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=2
-inherit eutils toolchain-funcs
-
-DESCRIPTION="An STL-like tree class"
-HOMEPAGE="http://www.aei.mpg.de/~peekas/tree/"
-SRC_URI="http://www.aei.mpg.de/~peekas/tree/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- # test was buggy, reported upstream
- epatch \
- "${FILESDIR}"/${PN}-2.62-test.patch \
- "${FILESDIR}"/${P}-gcc46.patch
-}
-
-src_test() {
- $(tc-getCXX) ${CXXFLAGS} test_tree.cc -o test_tree \
- || die "compile test failed"
- ./test_tree > mytest.output || die "running test failed"
- diff -Nu test_tree.output mytest.output || die "test dist failed"
-}
-
-src_install() {
- insinto /usr/include
- doins tree.hh tree_util.hh || die
- insinto /usr/share/doc/${PF}
- doins tree_example.cc || die
- if use doc; then
- doins tree.pdf || die
- fi
-}