summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2022-10-17 14:43:27 -0500
committerMatthias Maier <tamiko@gentoo.org>2022-10-17 14:44:41 -0500
commita3110e845c9d1ca426a53aa56e3ca8f40d152ead (patch)
tree538e2367d4a6a2e5cbab86768ed48a8376b85f1b /dev-cpp
parentsys-kernel/gentoo-sources: Auto stable 5.4.219 per kernel project policy (diff)
downloadgentoo-a3110e845c9d1ca426a53aa56e3ca8f40d152ead.tar.gz
gentoo-a3110e845c9d1ca426a53aa56e3ca8f40d152ead.tar.bz2
gentoo-a3110e845c9d1ca426a53aa56e3ca8f40d152ead.zip
dev-cpp/kokkos: add 3.7.0
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/kokkos/Manifest1
-rw-r--r--dev-cpp/kokkos/kokkos-3.7.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-cpp/kokkos/Manifest b/dev-cpp/kokkos/Manifest
index 4da29b139ece..e324387893fb 100644
--- a/dev-cpp/kokkos/Manifest
+++ b/dev-cpp/kokkos/Manifest
@@ -1 +1,2 @@
DIST kokkos-3.1.01.tar.gz 1972707 BLAKE2B fe31556ecba6b01ed6e480f0cb4ca4d7dc487d6b2a7e52df94d0e93b864ed5269a752f4fcdbacb55383e9dee3b72236f121b67d2f5eed10f3351219b063e7099 SHA512 4fa428ec33ec207147b3fcc5e0d297bcff4ed772ba6baa24ccaf56b691b72b70c69bd48fdf134f4e78234bf755377fe01a31611a41539c2d211ba9caed24b1f2
+DIST kokkos-3.7.0.tar.gz 2301343 BLAKE2B b63ffc7c70141396986414375143d4df62a4bfffec0f0a346a278819557b42a025cd7f2a0825cd4d2d7c94a5c7c374b58be79dae9c45e012574b4c87c2ae0371 SHA512 f72b43096126cba11129ab44c2ebaeb1ee92b14db45bd451e86f40746e8edbfbe3415dee089080a6664ae4985e5796717c64bb5c508ca5e287b31bac248802f6
diff --git a/dev-cpp/kokkos/kokkos-3.7.0.ebuild b/dev-cpp/kokkos/kokkos-3.7.0.ebuild
new file mode 100644
index 000000000000..b8f927d8aac1
--- /dev/null
+++ b/dev-cpp/kokkos/kokkos-3.7.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="C++ Performance Portability Programming EcoSystem"
+HOMEPAGE="https://github.com/kokkos"
+MY_PV="${PV}0"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 -x86"
+IUSE="+openmp test"
+RESTRICT="!test? ( test )"
+
+DEPEND="sys-apps/hwloc:="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_INCLUDEDIR=include/kokkos
+ -DKokkos_ENABLE_TESTS=$(usex test)
+ -DKokkos_ENABLE_AGGRESSIVE_VECTORIZATION=ON
+ -DKokkos_ENABLE_SERIAL=ON
+ -DKokkos_ENABLE_HWLOC=ON
+ -DKokkos_HWLOC_DIR="${EPREFIX}/usr"
+ -DKokkos_ENABLE_OPENMP=$(usex openmp)
+ -DBUILD_SHARED_LIBS=ON
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # Contains "death tests" which are known/expected(?) to fail
+ # https://github.com/kokkos/kokkos/issues/3033
+ # bug #791514
+ -E "(KokkosCore_UnitTest_OpenMP|KokkosCore_UnitTest_Serial)"
+ )
+
+ cmake_src_test
+}