summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-23 14:22:51 +0100
committerSam James <sam@gentoo.org>2023-05-23 14:25:04 +0100
commit50c1742c209ff94330d2b5642eceb4147352803c (patch)
treedc5b851d11533e985606ff7b407b2f634e787efb /dev-db/mongodb
parentsci-libs/trilinos: fix cmake configuration files (diff)
downloadgentoo-50c1742c209ff94330d2b5642eceb4147352803c.tar.gz
gentoo-50c1742c209ff94330d2b5642eceb4147352803c.tar.bz2
gentoo-50c1742c209ff94330d2b5642eceb4147352803c.zip
dev-db/mongodb: allow MAKEOPTS -jN > nproc
Closes: https://bugs.gentoo.org/906897 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db/mongodb')
-rw-r--r--dev-db/mongodb/mongodb-5.0.16-r1.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-db/mongodb/mongodb-5.0.16-r1.ebuild b/dev-db/mongodb/mongodb-5.0.16-r1.ebuild
index 763a51752883..a0fc28ebe45c 100644
--- a/dev-db/mongodb/mongodb-5.0.16-r1.ebuild
+++ b/dev-db/mongodb/mongodb-5.0.16-r1.ebuild
@@ -88,7 +88,7 @@ pkg_pretend() {
if use amd64 && ! use cpu_flags_x86_avx; then
ewarn "MongoDB 5.0 requires use of the AVX instruction set."
ewarn "This ebuild will use --experimental-optimization=-sandybridge which"
- ewarn "will result in an experimental build of MongoDB as per upstream."
+ ewarn "will result in an experimental build of MongoDB as per upstream."
ewarn "https://docs.mongodb.com/v5.0/administration/production-notes/"
fi
@@ -123,6 +123,7 @@ src_configure() {
CXX="$(tc-getCXX)"
--disable-warnings-as-errors
+ --force-jobs
--jobs="$(makeopts_jobs)"
--use-system-boost
--use-system-pcre