summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/pgrouting
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/pgrouting')
-rw-r--r--dev-db/pgrouting/Manifest1
-rw-r--r--dev-db/pgrouting/files/no-contrib-when-use-extension.patch76
-rw-r--r--dev-db/pgrouting/metadata.xml12
-rw-r--r--dev-db/pgrouting/pgrouting-2.0.0.ebuild102
4 files changed, 191 insertions, 0 deletions
diff --git a/dev-db/pgrouting/Manifest b/dev-db/pgrouting/Manifest
new file mode 100644
index 000000000000..602175e5e41b
--- /dev/null
+++ b/dev-db/pgrouting/Manifest
@@ -0,0 +1 @@
+DIST pgrouting-2.0.0.tar.gz 3765933 SHA256 606309e8ece04abec062522374b48179c16bddb30dd4c5080b89a4298e8d163b SHA512 4a74cc1ce1bbbb8d95ae2aabc712e30c97e0418b1e4f28a255ecd9e57577bd7081a52e6e64a63cb06c9ca659271273b37bdbefb94d49e69b9c2ce45e96911884 WHIRLPOOL ce7492fe1512f7829bd887a7acaadc6c276719fc7e00ceb68a702a2476a9464c83bf929ef78381c8d36a6575dee21587c204f798511e1430731064c2c48a0815
diff --git a/dev-db/pgrouting/files/no-contrib-when-use-extension.patch b/dev-db/pgrouting/files/no-contrib-when-use-extension.patch
new file mode 100644
index 000000000000..e26af3ef0da3
--- /dev/null
+++ b/dev-db/pgrouting/files/no-contrib-when-use-extension.patch
@@ -0,0 +1,76 @@
+diff -Naur pgrouting-2.0.0.orig/CMakeLists.txt pgrouting-2.0.0/CMakeLists.txt
+--- pgrouting-2.0.0.orig/CMakeLists.txt 2013-09-24 16:38:31.000000000 -0400
++++ pgrouting-2.0.0/CMakeLists.txt 2014-11-07 06:48:11.555026180 -0500
+@@ -170,16 +170,13 @@
+ OUTPUT_VARIABLE SHARE_DIR)
+
+ if(SHARE_DIR)
+- # Always install in "contrib" directory of PostgreSQL
+- set(CONTRIB_DIR "${SHARE_DIR}/contrib/pgrouting-${PGROUTING_VERSION_MAJOR}.${PGROUTING_VERSION_MINOR}")
+- message(STATUS "Contrib directory for SQL files is set to ${CONTRIB_DIR}")
+-
+ # Install as extension if supported by the version of PostgreSQL
+ if(USE_PG_EXTENSION)
+ set(SHARE_DIR "${SHARE_DIR}/extension")
+ message(STATUS "Extension directory for SQL files is set to ${SHARE_DIR}")
+- #else(USE_PG_EXTENSION)
+- # set(SHARE_DIR "/usr/share/pgrouting")
++ else(USE_PG_EXTENSION)
++ set(CONTRIB_DIR "${SHARE_DIR}/contrib/pgrouting-${PGROUTING_VERSION_MAJOR}.${PGROUTING_VERSION_MINOR}")
++ message(STATUS "Contrib directory for SQL files is set to ${CONTRIB_DIR}")
+ endif(USE_PG_EXTENSION)
+ else(SHARE_DIR)
+ message(FATAL_ERROR "pg_config --sharedir failed to return a value. Please check your PostgreSQL installation!")
+@@ -347,22 +344,24 @@
+
+ install(FILES ${LIBS_TO_INSTALL} DESTINATION ${LIB_DIR})
+
+-install(FILES
++if(USE_PG_EXTENSION)
++ install(FILES
+ "${CMAKE_BINARY_DIR}/lib/pgrouting--${PGROUTING_VERSION_STRING}.sql"
+ "${CMAKE_BINARY_DIR}/lib/pgrouting.control"
+ "${CMAKE_BINARY_DIR}/lib/pgrouting_legacy.sql"
+ DESTINATION "${SHARE_DIR}")
+-
+-# The following probably could be done better
+-# The idea is to also have a "pgrouting-x.x" directory in PostgreSQL contrib
+-configure_file("${CMAKE_BINARY_DIR}/lib/pgrouting--${PGROUTING_VERSION_STRING}.sql"
++else(USE_PG_EXTENSION)
++ # The following probably could be done better
++ # The idea is to also have a "pgrouting-x.x" directory in PostgreSQL contrib
++ configure_file("${CMAKE_BINARY_DIR}/lib/pgrouting--${PGROUTING_VERSION_STRING}.sql"
+ "${CMAKE_BINARY_DIR}/lib/pgrouting.sql" COPYONLY)
+
+-install(FILES
++ install(FILES
+ "${CMAKE_BINARY_DIR}/lib/pgrouting.sql"
+ "${CMAKE_BINARY_DIR}/lib/pgrouting.control"
+ "${CMAKE_BINARY_DIR}/lib/pgrouting_legacy.sql"
+ DESTINATION "${CONTRIB_DIR}")
++endif(USE_PG_EXTENSION)
+
+ # TODO: The following probably should be done better
+ if(WITH_DD)
+@@ -372,12 +371,14 @@
+ configure_file("${PGROUTING_SOURCE_DIR}/src/driving_distance/sql/routing_dd_legacy.sql"
+ "${CMAKE_BINARY_DIR}/lib/pgrouting_dd_legacy.sql" COPYONLY)
+
+- install(FILES
+- "${CMAKE_BINARY_DIR}/lib/pgrouting_dd_legacy.sql"
+- DESTINATION "${SHARE_DIR}")
+-
+- install(FILES
+- "${CMAKE_BINARY_DIR}/lib/pgrouting_dd_legacy.sql"
+- DESTINATION "${CONTRIB_DIR}")
++ if(USE_PG_EXTENSION)
++ install(FILES
++ "${CMAKE_BINARY_DIR}/lib/pgrouting_dd_legacy.sql"
++ DESTINATION "${SHARE_DIR}")
++ else(USE_PG_EXTENSION)
++ install(FILES
++ "${CMAKE_BINARY_DIR}/lib/pgrouting_dd_legacy.sql"
++ DESTINATION "${CONTRIB_DIR}")
++ endif(USE_PG_EXTENSION)
+ endif(WITH_DD)
+
diff --git a/dev-db/pgrouting/metadata.xml b/dev-db/pgrouting/metadata.xml
new file mode 100644
index 000000000000..fb3e2b441365
--- /dev/null
+++ b/dev-db/pgrouting/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>postgresql</herd>
+ <use>
+ <flag name="html">Install HTML formatted documentation</flag>
+ <flag name="drivingdistance">Enable to calculate driving distance</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">pgRouting/pgrouting</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/pgrouting/pgrouting-2.0.0.ebuild b/dev-db/pgrouting/pgrouting-2.0.0.ebuild
new file mode 100644
index 000000000000..5ef7d558993d
--- /dev/null
+++ b/dev-db/pgrouting/pgrouting-2.0.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+POSTGRES_COMPAT=( 9.{0,1,2,3,4} )
+
+inherit eutils cmake-utils
+
+DESCRIPTION="pgRouting extends PostGIS and PostgreSQL with geospatial routing functionality."
+HOMEPAGE="http://pgrouting.org/index.html"
+LICENSE="GPL-2 MIT Boost-1.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+SRC_URI="https://github.com/pgRouting/pgrouting/archive/v${PV}.tar.gz -> ${PN}-${PV}.tar.gz"
+IUSE="+drivingdistance doc pdf html"
+
+REQUIRED_USE="html? ( doc ) pdf? ( doc )"
+
+RDEPEND="
+ || (
+ dev-db/postgresql:9.4[server]
+ dev-db/postgresql:9.3[server]
+ dev-db/postgresql:9.2[server]
+ dev-db/postgresql:9.1[server]
+ dev-db/postgresql:9.0[server]
+ )
+ >=dev-db/postgis-2.0
+ dev-libs/boost
+ drivingdistance? ( sci-mathematics/cgal )
+"
+
+DEPEND="
+ doc? ( >=dev-python/sphinx-1.1 )
+ pdf? ( >=dev-python/sphinx-1.1[latex] )
+"
+
+# Needs a running psql instance, doesn't work out of the box
+RESTRICT="test"
+CMAKE_MIN_VERSION="2.8.8"
+
+postgres_check_slot() {
+ if ! declare -p POSTGRES_COMPAT &>/dev/null; then
+ die 'POSTGRES_COMPAT not declared.'
+ fi
+
+# Don't die because we can't run postgresql-config during pretend.
+[[ "$EBUILD_PHASE" = "pretend" \
+ && -z "$(which postgresql-config 2> /dev/null)" ]] && return 0
+
+ local res=$(echo ${POSTGRES_COMPAT[@]} \
+ | grep -c $(postgresql-config show 2> /dev/null) 2> /dev/null)
+
+ if [[ "$res" -eq "0" ]] ; then
+ eerror "PostgreSQL slot must be set to one of: "
+ eerror " ${POSTGRES_COMPAT[@]}"
+ return 1
+ fi
+
+ return 0
+}
+
+pkg_pretend() {
+ postgres_check_slot || die
+}
+
+pkg_setup() {
+ postgres_check_slot || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/no-contrib-when-use-extension.patch"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with drivingdistance DD)
+ $(cmake-utils_use_with doc DOC)
+ $(cmake-utils_use_build doc MAN)
+ $(cmake-utils_use_build html HTML)
+ $(cmake-utils_use_build pdf LATEX)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ local make_opts
+ use doc && make_opts="all doc"
+ cmake-utils_src_make ${make_opts}
+}
+
+src_install() {
+ use doc && doman "${BUILD_DIR}"/doc/man/en/pgrouting.7
+ use html && dohtml -r "${BUILD_DIR}"/doc/html/*
+ use pdf && dodoc "${BUILD_DIR}"/doc/latex/en/*.pdf
+
+ dodoc README* VERSION
+
+ cmake-utils_src_install
+}