summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-db/redis
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-db/redis')
-rw-r--r--dev-db/redis/redis-4.0.10.ebuild3
-rw-r--r--dev-db/redis/redis-4.0.11.ebuild3
-rw-r--r--dev-db/redis/redis-4.0.12.ebuild3
-rw-r--r--dev-db/redis/redis-4.0.13.ebuild1
-rw-r--r--dev-db/redis/redis-4.0.14.ebuild1
-rw-r--r--dev-db/redis/redis-4.0.2-r1.ebuild3
-rw-r--r--dev-db/redis/redis-5.0.3.ebuild1
-rw-r--r--dev-db/redis/redis-5.0.4.ebuild1
-rw-r--r--dev-db/redis/redis-5.0.5.ebuild1
9 files changed, 13 insertions, 4 deletions
diff --git a/dev-db/redis/redis-4.0.10.ebuild b/dev-db/redis/redis-4.0.10.ebuild
index 0062f6313ebb..be27d0c369e6 100644
--- a/dev-db/redis/redis-4.0.10.ebuild
+++ b/dev-db/redis/redis-4.0.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,6 +12,7 @@ SRC_URI="http://download.redis.io/releases/${P}.tar.gz"
LICENSE="BSD"
KEYWORDS="amd64 arm arm64 ~hppa ~ppc ppc64 x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
IUSE="+jemalloc tcmalloc luajit test"
+RESTRICT="!test? ( test )"
SLOT="0"
# Redis does NOT build with Lua 5.2 or newer at this time.
diff --git a/dev-db/redis/redis-4.0.11.ebuild b/dev-db/redis/redis-4.0.11.ebuild
index a8d59c405e63..ee9220186854 100644
--- a/dev-db/redis/redis-4.0.11.ebuild
+++ b/dev-db/redis/redis-4.0.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,6 +12,7 @@ SRC_URI="http://download.redis.io/releases/${P}.tar.gz"
LICENSE="BSD"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
IUSE="+jemalloc tcmalloc luajit test"
+RESTRICT="!test? ( test )"
SLOT="0"
# Redis does NOT build with Lua 5.2 or newer at this time.
diff --git a/dev-db/redis/redis-4.0.12.ebuild b/dev-db/redis/redis-4.0.12.ebuild
index 596754bc3a07..ee9220186854 100644
--- a/dev-db/redis/redis-4.0.12.ebuild
+++ b/dev-db/redis/redis-4.0.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,6 +12,7 @@ SRC_URI="http://download.redis.io/releases/${P}.tar.gz"
LICENSE="BSD"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
IUSE="+jemalloc tcmalloc luajit test"
+RESTRICT="!test? ( test )"
SLOT="0"
# Redis does NOT build with Lua 5.2 or newer at this time.
diff --git a/dev-db/redis/redis-4.0.13.ebuild b/dev-db/redis/redis-4.0.13.ebuild
index a1d588da3ae0..ee9220186854 100644
--- a/dev-db/redis/redis-4.0.13.ebuild
+++ b/dev-db/redis/redis-4.0.13.ebuild
@@ -12,6 +12,7 @@ SRC_URI="http://download.redis.io/releases/${P}.tar.gz"
LICENSE="BSD"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
IUSE="+jemalloc tcmalloc luajit test"
+RESTRICT="!test? ( test )"
SLOT="0"
# Redis does NOT build with Lua 5.2 or newer at this time.
diff --git a/dev-db/redis/redis-4.0.14.ebuild b/dev-db/redis/redis-4.0.14.ebuild
index cc327916f83f..5ca8d4bae3db 100644
--- a/dev-db/redis/redis-4.0.14.ebuild
+++ b/dev-db/redis/redis-4.0.14.ebuild
@@ -12,6 +12,7 @@ SRC_URI="http://download.redis.io/releases/${P}.tar.gz"
LICENSE="BSD"
KEYWORDS="amd64 arm arm64 hppa ~ppc ppc64 x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
IUSE="+jemalloc tcmalloc luajit test"
+RESTRICT="!test? ( test )"
SLOT="0"
# Redis does NOT build with Lua 5.2 or newer at this time.
diff --git a/dev-db/redis/redis-4.0.2-r1.ebuild b/dev-db/redis/redis-4.0.2-r1.ebuild
index dd90a7deb368..510cd9b08c0d 100644
--- a/dev-db/redis/redis-4.0.2-r1.ebuild
+++ b/dev-db/redis/redis-4.0.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,6 +12,7 @@ SRC_URI="http://download.redis.io/releases/${P}.tar.gz"
LICENSE="BSD"
KEYWORDS="amd64 arm arm64 hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
IUSE="+jemalloc tcmalloc luajit test"
+RESTRICT="!test? ( test )"
SLOT="0"
# Redis does NOT build with Lua 5.2 or newer at this time.
diff --git a/dev-db/redis/redis-5.0.3.ebuild b/dev-db/redis/redis-5.0.3.ebuild
index c584f33c21fc..c40f7c3c47cd 100644
--- a/dev-db/redis/redis-5.0.3.ebuild
+++ b/dev-db/redis/redis-5.0.3.ebuild
@@ -12,6 +12,7 @@ SRC_URI="http://download.redis.io/releases/${P}.tar.gz"
LICENSE="BSD"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
IUSE="+jemalloc tcmalloc luajit test"
+RESTRICT="!test? ( test )"
SLOT="0"
# Redis does NOT build with Lua 5.2 or newer at this time.
diff --git a/dev-db/redis/redis-5.0.4.ebuild b/dev-db/redis/redis-5.0.4.ebuild
index 07c6466e9a12..1b0f17be18b6 100644
--- a/dev-db/redis/redis-5.0.4.ebuild
+++ b/dev-db/redis/redis-5.0.4.ebuild
@@ -12,6 +12,7 @@ SRC_URI="http://download.redis.io/releases/${P}.tar.gz"
LICENSE="BSD"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
IUSE="+jemalloc tcmalloc luajit test"
+RESTRICT="!test? ( test )"
SLOT="0"
# Redis does NOT build with Lua 5.2 or newer at this time.
diff --git a/dev-db/redis/redis-5.0.5.ebuild b/dev-db/redis/redis-5.0.5.ebuild
index 07c6466e9a12..1b0f17be18b6 100644
--- a/dev-db/redis/redis-5.0.5.ebuild
+++ b/dev-db/redis/redis-5.0.5.ebuild
@@ -12,6 +12,7 @@ SRC_URI="http://download.redis.io/releases/${P}.tar.gz"
LICENSE="BSD"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
IUSE="+jemalloc tcmalloc luajit test"
+RESTRICT="!test? ( test )"
SLOT="0"
# Redis does NOT build with Lua 5.2 or newer at this time.