summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-03-16 13:44:48 -0700
committerZac Medico <zmedico@gentoo.org>2019-03-16 14:42:57 -0700
commitdeb103eb7ba2cfe4f2f55c5809ee89c4b8653aad (patch)
tree5a8b3b1d63005e2664953260de0bd25b082444b2 /dev-go
parentdev-lang/mono-basic: amd64 stable wrt bug #676234 (diff)
downloadgentoo-deb103eb7ba2cfe4f2f55c5809ee89c4b8653aad.tar.gz
gentoo-deb103eb7ba2cfe4f2f55c5809ee89c4b8653aad.tar.bz2
gentoo-deb103eb7ba2cfe4f2f55c5809ee89c4b8653aad.zip
dev-go/go-tools: filter GOCACHE vars (bug 678964)
Reported-by: Toralf Förster <toralf@gentoo.org> Closes: https://bugs.gentoo.org/678964 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-tools/go-tools-0_pre20180817.ebuild3
-rw-r--r--dev-go/go-tools/go-tools-9999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/dev-go/go-tools/go-tools-0_pre20180817.ebuild b/dev-go/go-tools/go-tools-0_pre20180817.ebuild
index 5191bd7e69ca..a7bd294e6203 100644
--- a/dev-go/go-tools/go-tools-0_pre20180817.ebuild
+++ b/dev-go/go-tools/go-tools-0_pre20180817.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -47,6 +47,7 @@ src_prepare() {
}
src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #678964
# Generate static.go with favicon included
pushd src/golang.org/x/tools/godoc/static >/dev/null || die
GOPATH="${S}:$(get_golibdir_gopath)" \
diff --git a/dev-go/go-tools/go-tools-9999.ebuild b/dev-go/go-tools/go-tools-9999.ebuild
index fb8bd018f99d..ffc68729ed0b 100644
--- a/dev-go/go-tools/go-tools-9999.ebuild
+++ b/dev-go/go-tools/go-tools-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -65,6 +65,7 @@ src_prepare() {
}
src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME #678964
# Generate static.go with favicon included
pushd src/golang.org/x/tools/godoc/static >/dev/null || die
GOPATH="${S}" GOBIN="${S}/bin" \