summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/asn1-encoding
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/asn1-encoding')
-rw-r--r--dev-haskell/asn1-encoding/Manifest2
-rw-r--r--dev-haskell/asn1-encoding/asn1-encoding-0.8.1.3.ebuild37
-rw-r--r--dev-haskell/asn1-encoding/asn1-encoding-0.9.0.ebuild31
-rw-r--r--dev-haskell/asn1-encoding/metadata.xml11
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-haskell/asn1-encoding/Manifest b/dev-haskell/asn1-encoding/Manifest
new file mode 100644
index 000000000000..ac28ee66328f
--- /dev/null
+++ b/dev-haskell/asn1-encoding/Manifest
@@ -0,0 +1,2 @@
+DIST asn1-encoding-0.8.1.3.tar.gz 16099 SHA256 d1a26d9e2df6f0c815ff347093b20e06a21feeaee2f9204af7aeb797ba541900 SHA512 be5d97db5904cb71fd99db919a6da8e958b3e0aedaea6bbd21d316fc41dd79852d8567edecb75eb212279a9f6af3d566d3e8aa5f5f22f46a8d9ca0883af64dd9 WHIRLPOOL 62621fb12fddf2e090056c2c37fe76ec751f7fba68906cdaaa0629894ebd7227361439b32c321eee09563a79dad1ff8d6f263134c685d677c9de80d49663e375
+DIST asn1-encoding-0.9.0.tar.gz 15997 SHA256 17e9194f41b5a85a733fb54ee4a0c8466f6f67462f53c1e8a05b3d42fda7a30b SHA512 b7693c74ba01d46d93371faa1df14bdef233b8b0fcbd4de0d6a853e41795622e1edc79c278372976454107d97f8a6ba10c44cab2539103796d56b9df4fa4b0ee WHIRLPOOL 3aec02a703169248d1ef4c6b793e4b26576dacb2b0b5c601dc85593f381279eb2469f515ff4f37f4de8c530834907ec552a67b74baea4d4875988f86d05b2df6
diff --git a/dev-haskell/asn1-encoding/asn1-encoding-0.8.1.3.ebuild b/dev-haskell/asn1-encoding/asn1-encoding-0.8.1.3.ebuild
new file mode 100644
index 000000000000..90fe1d29f555
--- /dev/null
+++ b/dev-haskell/asn1-encoding/asn1-encoding-0.8.1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="ASN1 data reader and writer in RAW, BER and DER forms"
+HOMEPAGE="http://github.com/vincenthz/hs-asn1"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-haskell/asn1-types-0.2.1:=[profile?] <dev-haskell/asn1-types-0.3:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+ test? ( dev-haskell/hunit:=[profile?]
+ >=dev-haskell/quickcheck-2:2=[profile?]
+ >=dev-haskell/test-framework-0.3:=[profile?]
+ >=dev-haskell/test-framework-quickcheck2-0.2:=[profile?] )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test test)
+}
diff --git a/dev-haskell/asn1-encoding/asn1-encoding-0.9.0.ebuild b/dev-haskell/asn1-encoding/asn1-encoding-0.9.0.ebuild
new file mode 100644
index 000000000000..4fb1a540ca8c
--- /dev/null
+++ b/dev-haskell/asn1-encoding/asn1-encoding-0.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="ASN1 data reader and writer in RAW, BER and DER forms"
+HOMEPAGE="http://github.com/vincenthz/hs-asn1"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/asn1-types-0.3.0:=[profile?] <dev-haskell/asn1-types-0.4:=[profile?]
+ >=dev-haskell/hourglass-0.2.6:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-quickcheck
+ dev-haskell/text )
+"
diff --git a/dev-haskell/asn1-encoding/metadata.xml b/dev-haskell/asn1-encoding/metadata.xml
new file mode 100644
index 000000000000..ac4d879b20d6
--- /dev/null
+++ b/dev-haskell/asn1-encoding/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ ASN1 data reader and writer in raw form with supports for high level forms of ASN1 (BER, and DER).
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-asn1</remote-id>
+ </upstream>
+</pkgmetadata>