summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/cabal-install/cabal-install-1.20.0.3-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/cabal-install/cabal-install-1.20.0.3-r2.ebuild')
-rw-r--r--dev-haskell/cabal-install/cabal-install-1.20.0.3-r2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-haskell/cabal-install/cabal-install-1.20.0.3-r2.ebuild b/dev-haskell/cabal-install/cabal-install-1.20.0.3-r2.ebuild
new file mode 100644
index 000000000000..c10b900a3e82
--- /dev/null
+++ b/dev-haskell/cabal-install/cabal-install-1.20.0.3-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="bin test-suite"
+inherit bash-completion-r1 eutils haskell-cabal
+
+DESCRIPTION="The command-line interface for Cabal and Hackage"
+HOMEPAGE="http://www.haskell.org/cabal/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+noprefs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.20.0 <dev-haskell/cabal-1.21
+ >=dev-haskell/http-4000.2.5 <dev-haskell/http-4000.3
+ >=dev-haskell/mtl-2.0 <dev-haskell/mtl-3
+ >=dev-haskell/network-2.0 <dev-haskell/network-2.7
+ dev-haskell/network-uri
+ >=dev-haskell/random-1 <dev-haskell/random-1.2
+ >=dev-haskell/stm-2.0 <dev-haskell/stm-3
+ >=dev-haskell/zlib-0.5.3 <dev-haskell/zlib-0.6
+ >=dev-lang/ghc-7.4.1
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.5
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.3 )
+"
+
+src_prepare() {
+ if use noprefs; then
+ epatch "${FILESDIR}/${PN}"-0.13.3-nopref.patch
+ fi
+
+ # no chance to link to -threaded on ppc64, alpha and others
+ # who use UNREG, not only ARM
+ if ! ghc-supports-threaded-runtime; then
+ cabal_chdeps '-threaded' ' '
+ fi
+
+ cabal_chdeps \
+ 'network >= 2.0 && < 2.6' 'network >= 2.0 && < 2.7, network-uri' \
+ 'network,' 'network,network-uri,' \
+ 'random >= 1 && < 1.1' 'random >= 1 && < 1.2'
+}
+
+src_install() {
+ haskell-cabal_src_install
+
+ dobashcomp "${S}/bash-completion/cabal"
+}