summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/hstringtemplate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/hstringtemplate')
-rw-r--r--dev-haskell/hstringtemplate/Manifest2
-rw-r--r--dev-haskell/hstringtemplate/hstringtemplate-0.7.3.ebuild37
-rw-r--r--dev-haskell/hstringtemplate/hstringtemplate-0.8.3.ebuild37
-rw-r--r--dev-haskell/hstringtemplate/metadata.xml8
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-haskell/hstringtemplate/Manifest b/dev-haskell/hstringtemplate/Manifest
new file mode 100644
index 000000000000..6979a1f12560
--- /dev/null
+++ b/dev-haskell/hstringtemplate/Manifest
@@ -0,0 +1,2 @@
+DIST HStringTemplate-0.7.3.tar.gz 15961 SHA256 883fbfd35c14ab46cd1545a8643da700094297f0cb74462f460781694dd884bf SHA512 987e827dabf64f13df9ec584c6ac4d9b121bec07543f9600e212c1a20fe03aa1fcb24f8f669b5ae53f85e4ec9d2d6a7c76a2845496a8440332b601c64fcb552c WHIRLPOOL 73d865399184cc177d786cf85423675dc0b4abe309679666270f59122e13e2d88529eced90fa1abeb13a9a2074acf77c6edca6f673fa5f1503e33fc880f90d6e
+DIST HStringTemplate-0.8.3.tar.gz 16023 SHA256 63d6b1c993f5612ef370b92bb8fab05323657ec34a0f35110b967eb853239d18 SHA512 d356ea7defea10535f5ec188a4bdc6ecba89f447c509af04421753dc9b0f4cf85aa24ec1dd2c8ba0b31bfef06576e0a9f8c457e890468244bae22abc47d26f8e WHIRLPOOL 7ea5cb6975c54890e9f7e48fc0ed9fc59925bc0d7d80a7d8fdcf13b67aec67c42f3a0547c479ac6d452a0258141762aacefd329b611d9c3020c65c36228dcc75
diff --git a/dev-haskell/hstringtemplate/hstringtemplate-0.7.3.ebuild b/dev-haskell/hstringtemplate/hstringtemplate-0.7.3.ebuild
new file mode 100644
index 000000000000..3abcabed3dac
--- /dev/null
+++ b/dev-haskell/hstringtemplate/hstringtemplate-0.7.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HStringTemplate"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="StringTemplate implementation in Haskell"
+HOMEPAGE="http://hackage.haskell.org/package/HStringTemplate"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/blaze-builder:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ <dev-haskell/parsec-4:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ dev-haskell/void:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/hstringtemplate/hstringtemplate-0.8.3.ebuild b/dev-haskell/hstringtemplate/hstringtemplate-0.8.3.ebuild
new file mode 100644
index 000000000000..7a602eb114fa
--- /dev/null
+++ b/dev-haskell/hstringtemplate/hstringtemplate-0.8.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HStringTemplate"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="StringTemplate implementation in Haskell"
+HOMEPAGE="http://hackage.haskell.org/package/HStringTemplate"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/blaze-builder:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/old-locale:=[profile?]
+ <dev-haskell/parsec-4:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/void:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/hstringtemplate/metadata.xml b/dev-haskell/hstringtemplate/metadata.xml
new file mode 100644
index 000000000000..41baef021a3b
--- /dev/null
+++ b/dev-haskell/hstringtemplate/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A port of the Java library by Terrence Parr.
+ </longdescription>
+</pkgmetadata>