summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-12-14 20:36:07 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-12-14 21:27:02 +0000
commit0a4c194b91d3aee19f7d6f56966ce64673788437 (patch)
tree6201fd2d30912b949da596fce494dcbebd6fd428 /dev-haskell/htf
parentdev-haskell/http: bump up to 4000.3.14 (diff)
downloadgentoo-0a4c194b91d3aee19f7d6f56966ce64673788437.tar.gz
gentoo-0a4c194b91d3aee19f7d6f56966ce64673788437.tar.bz2
gentoo-0a4c194b91d3aee19f7d6f56966ce64673788437.zip
dev-haskell/htf: bump up to 0.13.2.5
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/htf')
-rw-r--r--dev-haskell/htf/Manifest1
-rw-r--r--dev-haskell/htf/htf-0.13.2.5.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/htf/Manifest b/dev-haskell/htf/Manifest
index ac05d7b931a2..61389c69d6a7 100644
--- a/dev-haskell/htf/Manifest
+++ b/dev-haskell/htf/Manifest
@@ -1 +1,2 @@
DIST HTF-0.13.1.0.tar.gz 78310 BLAKE2B eab7a9c2eb05246dbd413f31c32554b01527211bb469ceec8a54d11e427ca74ee706640fe3d49fc40486a238db4e284ce97511c371e7eb7161d65cb841f77a76 SHA512 1292f8f0b9189e1ce05de1cf6f686ce77a839c4191a5f8b8000c8d740abe4b8f457a7c5ed8aadc13221fe9fde9b4c15bde9f9f6f53ac03178cd1884572fb4069
+DIST HTF-0.13.2.5.tar.gz 79761 BLAKE2B 2caf1ea1192087fd614f097a45508d290cfb2a7f7633f262c7b3b37d1f1bf23d7a3cb0b7746a6b2f619b41e08500f6ce1d1a4700ae216a0641e4edd1c5db5b03 SHA512 2c68a74c6492343d21405965776d3ee7c2930677c626c5353953d53274213bee0cf803c1b6f14600759c89eb0a66db4d248af75263e6c5f1bb5a39f569b6af78
diff --git a/dev-haskell/htf/htf-0.13.2.5.ebuild b/dev-haskell/htf/htf-0.13.2.5.ebuild
new file mode 100644
index 000000000000..d69d9e380af8
--- /dev/null
+++ b/dev-haskell/htf/htf-0.13.2.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite: needs htfpp already installed
+inherit haskell-cabal
+
+MY_PN="HTF"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The Haskell Test Framework"
+HOMEPAGE="https://github.com/skogsbaer/HTF/"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # needs stack, needs htfpp already installed
+
+RDEPEND=">=dev-haskell/aeson-0.11:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/cpphs-1.19:=[profile?]
+ >=dev-haskell/diff-0.3:=[profile?]
+ dev-haskell/haskell-src:=[profile?]
+ >=dev-haskell/hunit-1.2.5:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?]
+ >=dev-haskell/mtl-1.1:=[profile?]
+ >=dev-haskell/old-time-1.0:=[profile?]
+ >=dev-haskell/quickcheck-2.3:2=[profile?]
+ >=dev-haskell/random-1.0:=[profile?]
+ >=dev-haskell/regex-compat-0.92:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-haskell/xmlgen-0.6:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+"
+
+S="${WORKDIR}/${MY_P}"