summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/http-client
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/http-client')
-rw-r--r--dev-haskell/http-client/Manifest3
-rw-r--r--dev-haskell/http-client/http-client-0.2.2.2.ebuild40
-rw-r--r--dev-haskell/http-client/http-client-0.3.3.2.ebuild47
-rw-r--r--dev-haskell/http-client/http-client-0.4.18.1.ebuild51
-rw-r--r--dev-haskell/http-client/metadata.xml14
5 files changed, 155 insertions, 0 deletions
diff --git a/dev-haskell/http-client/Manifest b/dev-haskell/http-client/Manifest
new file mode 100644
index 000000000000..026c93e8363f
--- /dev/null
+++ b/dev-haskell/http-client/Manifest
@@ -0,0 +1,3 @@
+DIST http-client-0.2.2.2.tar.gz 29315 SHA256 91f642fbd612587ff088973e6aab6f59a8199d5068fdc9eb1bcea1b5f046c3de SHA512 c436a275848d4bac7d44f56b033303380f5b6433ab0064048c6e47977192bc81c2ae66b629af573e743274895797bfaf8ebd5c19c67c7583160508ba20e0597a WHIRLPOOL 0dd13cf62f79c56e5738dd5018dfdcae3fb18d4b9c49a1eda221a2ebac475ee4dcb03ee43524c0f9b844914bd005e98c2fb8996e2dc152c1926162490ca96dd1
+DIST http-client-0.3.3.2.tar.gz 33517 SHA256 67cecbfcbccf53c4a1287aed3f22a6cfc156640ace4f6ed004ce5166e0fd020b SHA512 7e05ab5f3c1a02092c1431f532a41cf032c791ea527ad84ee5d1e6ad9fb61decaa5b8e1f879099c47937c7c48a96961ee76d688fc42cb19878c6782922ece91e WHIRLPOOL be2de3b8215990e14b7711e0049541b619267d817fafb27c038c5f124a553f5e74959458d4609a74d3cc1650d7e18d8abf1a04ad57af1939e3ba29fc9d8cdfd4
+DIST http-client-0.4.18.1.tar.gz 75796 SHA256 69bba520e4719b5f2b1f2ce5bebea441d082691b76bef37c9fff410497ae156c SHA512 22b04e04edda5d0ae017acfd6b332acd9347d722245642f02caced4c60baa3b00d14e495c1b8f82e96e9c071acc045f0ab3f17b93706c95b81658a43489ac9f8 WHIRLPOOL 388790b6e17c7b3dd4e2cd002c21fdbd606e3e80d8e0c6d96cc1fcdd634e42a95d03bc761df66b7d03d9e7e6ec869f559c5859b44488a4501a3c154d2df42892
diff --git a/dev-haskell/http-client/http-client-0.2.2.2.ebuild b/dev-haskell/http-client/http-client-0.2.2.2.ebuild
new file mode 100644
index 000000000000..05825ad3dbe0
--- /dev/null
+++ b/dev-haskell/http-client/http-client-0.2.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An HTTP client engine, intended as a base layer for more user-friendly packages"
+HOMEPAGE="https://github.com/snoyberg/http-client"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-1.0:=[profile?] <dev-haskell/case-insensitive-1.2:=[profile?]
+ dev-haskell/cookie:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/failure-0.2:=[profile?] <dev-haskell/failure-0.3:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ dev-haskell/publicsuffixlist:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-haskell/zlib-bindings-0.1:=[profile?] <dev-haskell/zlib-bindings-0.2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/hspec
+ dev-haskell/monad-control
+ dev-haskell/zlib )
+"
diff --git a/dev-haskell/http-client/http-client-0.3.3.2.ebuild b/dev-haskell/http-client/http-client-0.3.3.2.ebuild
new file mode 100644
index 000000000000..caca74a8faba
--- /dev/null
+++ b/dev-haskell/http-client/http-client-0.3.3.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An HTTP client engine, intended as a base layer for more user-friendly packages"
+HOMEPAGE="https://github.com/snoyberg/http-client"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-1.0:=[profile?]
+ dev-haskell/cookie:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/exceptions-0.4:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?]
+ dev-haskell/mime-types:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ dev-haskell/publicsuffixlist:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-haskell/streaming-commons-0.1.0.2:=[profile?] <dev-haskell/streaming-commons-0.2:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/async
+ dev-haskell/hspec
+ dev-haskell/monad-control
+ >=dev-haskell/streaming-commons-0.1.1
+ dev-haskell/zlib )
+"
+
+# Prior to version 0.4.6.1, the test suite required internet access.
+RESTRICT="test"
diff --git a/dev-haskell/http-client/http-client-0.4.18.1.ebuild b/dev-haskell/http-client/http-client-0.4.18.1.ebuild
new file mode 100644
index 000000000000..c8fe2311bfe9
--- /dev/null
+++ b/dev-haskell/http-client/http-client-0.4.18.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An HTTP client engine, intended as a base layer for more user-friendly packages"
+HOMEPAGE="https://github.com/snoyberg/http-client"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND=">=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-1.0:=[profile?]
+ dev-haskell/cookie:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/exceptions-0.4:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?]
+ dev-haskell/mime-types:=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-haskell/streaming-commons-0.1.0.2:=[profile?] <dev-haskell/streaming-commons-0.2:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-2.6:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( >=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/async
+ dev-haskell/hspec
+ dev-haskell/monad-control
+ >=dev-haskell/streaming-commons-0.1.1
+ dev-haskell/zlib
+ !network-uri? ( dev-haskell/network-uri ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}
diff --git a/dev-haskell/http-client/metadata.xml b/dev-haskell/http-client/metadata.xml
new file mode 100644
index 000000000000..edb374e357be
--- /dev/null
+++ b/dev-haskell/http-client/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This codebase has been refactored from http-conduit.
+ </longdescription>
+ <use>
+ <flag name="network-uri">Get Network.URI from the network-uri package.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">snoyberg/http-client</remote-id>
+ </upstream>
+</pkgmetadata>