summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-02 12:33:13 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-02 12:33:21 +0100
commit876d9a45da5893f1f273011e053e861f046d589b (patch)
tree3ad7f4746ffa3fe60f5c90845debf8ebf029f14a /dev-haskell/hxt
parentmedia-sound/guimup: Drop last-rited package (diff)
downloadgentoo-876d9a45da5893f1f273011e053e861f046d589b.tar.gz
gentoo-876d9a45da5893f1f273011e053e861f046d589b.tar.bz2
gentoo-876d9a45da5893f1f273011e053e861f046d589b.zip
dev-haskell/hxt: unconditionally use network-uri
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/735184 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/hxt')
-rw-r--r--dev-haskell/hxt/hxt-9.3.1.18.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-haskell/hxt/hxt-9.3.1.18.ebuild b/dev-haskell/hxt/hxt-9.3.1.18.ebuild
index 1902e81622f6..2a562ce245da 100644
--- a/dev-haskell/hxt/hxt-9.3.1.18.ebuild
+++ b/dev-haskell/hxt/hxt-9.3.1.18.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,7 +15,7 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
-IUSE="+network-uri"
+IUSE=""
RDEPEND=">=dev-haskell/hxt-charproperties-9.1:=[profile?]
>=dev-haskell/hxt-regex-xmlschema-9.2:=[profile?]
@@ -23,8 +23,7 @@ RDEPEND=">=dev-haskell/hxt-charproperties-9.1:=[profile?]
>=dev-haskell/mtl-2.0.1:=[profile?] <dev-haskell/mtl-3:=[profile?]
>=dev-haskell/parsec-2.1:=[profile?] <dev-haskell/parsec-4:=[profile?]
>=dev-lang/ghc-7.4.1:=
- network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
- !network-uri? ( >=dev-haskell/network-2.4:=[profile?] <dev-haskell/network-2.6:=[profile?] )
+ >=dev-haskell/network-uri-2.6:=[profile?]
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
@@ -32,5 +31,5 @@ DEPEND="${RDEPEND}
src_configure() {
haskell-cabal_src_configure \
- $(cabal_flag network-uri network-uri)
+ --flag=network-uri
}