summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-12-20 18:36:19 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-12-20 18:36:27 +0000
commit43cc4f459b7d19bdc59b82db2c49f1e68f28957d (patch)
treedb0db7e34a98084ca26a975f0baa7dc705bb5610 /dev-haskell/parsec
parentapp-text/epspdf: Stabilize 0.6.3-r1 arm, #760360 (diff)
downloadgentoo-43cc4f459b7d19bdc59b82db2c49f1e68f28957d.tar.gz
gentoo-43cc4f459b7d19bdc59b82db2c49f1e68f28957d.tar.bz2
gentoo-43cc4f459b7d19bdc59b82db2c49f1e68f28957d.zip
dev-haskell/parsec: drop tests circular dependency
Reported-by: Toralf Förster Bug: https://bugs.gentoo.org/760863 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/parsec')
-rw-r--r--dev-haskell/parsec/metadata.xml18
-rw-r--r--dev-haskell/parsec/parsec-3.1.13.0-r1.ebuild14
-rw-r--r--dev-haskell/parsec/parsec-3.1.14.0.ebuild11
3 files changed, 19 insertions, 24 deletions
diff --git a/dev-haskell/parsec/metadata.xml b/dev-haskell/parsec/metadata.xml
index e593d5b00bd3..93067ba142c1 100644
--- a/dev-haskell/parsec/metadata.xml
+++ b/dev-haskell/parsec/metadata.xml
@@ -1,10 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- </maintainer>
- <upstream>
- <remote-id type="github">aslatter/parsec</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Parsec is designed from scratch as an industrial-strength parser
+ library. It is simple, safe, well documented (on the package
+ homepage), has extensive libraries and good error messages,
+ and is also fast. It is defined as a monad transformer that can be
+ stacked on arbitrary monads, and it is also parametric in the
+ input stream type.
+ </longdescription>
</pkgmetadata>
diff --git a/dev-haskell/parsec/parsec-3.1.13.0-r1.ebuild b/dev-haskell/parsec/parsec-3.1.13.0-r1.ebuild
index 9999fac242a9..0a7c5b66927a 100644
--- a/dev-haskell/parsec/parsec-3.1.13.0-r1.ebuild
+++ b/dev-haskell/parsec/parsec-3.1.13.0-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
# ebuild generated by hackport 0.5.5.9999
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Circulare depends: test-suite"
# break circular dependencies:
# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
CABAL_FEATURES+=" nocabaldep"
@@ -17,11 +17,10 @@ SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
-#keep in sync with ghc-8.6
-#KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
-RESTRICT=test # circular dependencies
+RESTRICT=test # circular dependencies: dev-haskell/base-orphans->cabal->parsec[test]->test-framework-hunit->test-framework->base-orphans
RDEPEND=">=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
>=dev-haskell/mtl-1.1.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
@@ -29,12 +28,7 @@ RDEPEND=">=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
>=dev-haskell/text-0.11.3:=[profile?] <dev-haskell/text-1.3:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
-DEPEND="${RDEPEND}
- test? ( >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
- >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4
- || ( ( >=dev-haskell/hunit-1.3.1.2 <dev-haskell/hunit-1.4 )
- ( >=dev-haskell/hunit-1.6 <dev-haskell/hunit-1.7 ) ) )
-"
+DEPEND="${RDEPEND}"
CABAL_CORE_LIB_GHC_PV="PM:8.4.2_rc1 PM:8.4.2 PM:8.4.3 PM:8.4.4 PM:8.6.1 PM:8.6.2 PM:8.6.3 PM:8.6.4 PM:8.6.5 PM:9999"
diff --git a/dev-haskell/parsec/parsec-3.1.14.0.ebuild b/dev-haskell/parsec/parsec-3.1.14.0.ebuild
index fde0a720b3b4..7cebba59ce2d 100644
--- a/dev-haskell/parsec/parsec-3.1.14.0.ebuild
+++ b/dev-haskell/parsec/parsec-3.1.14.0.ebuild
@@ -5,7 +5,7 @@ EAPI=7
# ebuild generated by hackport 0.6.9999
-CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite has circular depends
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Circular depens: test-suite"
# break circular dependencies:
# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
CABAL_FEATURES+=" nocabaldep"
@@ -21,7 +21,7 @@ SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
-RESTRICT=test # circular dependencies
+RESTRICT=test # circular dependencies: dev-haskell/base-orphans->cabal->parsec[test]->test-framework-hunit->test-framework->base-orphans
RDEPEND=">=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
>=dev-haskell/mtl-1.1.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
@@ -30,10 +30,5 @@ RDEPEND=">=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
>=dev-haskell/text-0.11.3.1:=[profile?] <dev-haskell/text-1.3:=[profile?]
"
DEPEND="${RDEPEND}"
-# test? ( >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
-# >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4
-# || ( ( >=dev-haskell/hunit-1.3.1.2 <dev-haskell/hunit-1.4 )
-# ( >=dev-haskell/hunit-1.6 <dev-haskell/hunit-1.7 ) ) )
-# "
-CABAL_CORE_LIB_GHC_PV="PM:8.8.1 PM:8.8.2 PM:8.8.3 PM:8.8.4 PM:8.10.1_alpha1 PM:8.10.1_alpha2 PM:8.10.1 PM:9999"
+CABAL_CORE_LIB_GHC_PV="PM:8.8.1 PM:8.8.2 PM:8.8.3 PM:8.8.4 PM:8.10.1_alpha1 PM:8.10.1_alpha2 PM:8.10.1 PM:8.10.2 PM:9999"