summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jal
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jal')
-rw-r--r--dev-java/jal/Manifest1
-rw-r--r--dev-java/jal/files/buildxml.patch18
-rw-r--r--dev-java/jal/jal-20031117-r3.ebuild46
-rw-r--r--dev-java/jal/metadata.xml15
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-java/jal/Manifest b/dev-java/jal/Manifest
new file mode 100644
index 000000000000..0ddf241455f2
--- /dev/null
+++ b/dev-java/jal/Manifest
@@ -0,0 +1 @@
+DIST jal-20031117-src.tar.gz 48793 SHA256 2f1bfd0c9b56a362da8fa5b61af3fd0722bb80e5b89fb12291b5a40e9f21db75 SHA512 0cb6cbd5e80d38dfbf57417b756dbc3bdddb2a28c4cbec292799ee71ac86cff3121f1e09e86f976f6562dafac54835bdd58780e4f1ffe733897b6d6ef053f95e WHIRLPOOL 54e9b1a005e2b10f62bcfd43bf1cf512fc0d0479ad113cfc57e3188f90b23184e1d6340ca56736faf7f309fc88196498652d459c75cbca7e2f76889ed3ac1568
diff --git a/dev-java/jal/files/buildxml.patch b/dev-java/jal/files/buildxml.patch
new file mode 100644
index 000000000000..16e39c93e222
--- /dev/null
+++ b/dev-java/jal/files/buildxml.patch
@@ -0,0 +1,18 @@
+diff -uprN jal-20031117.orig/build.xml jal-20031117/build.xml
+--- jal-20031117.orig/build.xml 2004-11-22 17:00:41.200663880 +0100
++++ jal-20031117/build.xml 2004-11-22 20:00:39.322099904 +0100
+@@ -16,11 +16,13 @@
+ debug="on"
+ optimize="on"
+ destdir="${build}"
++ source="1.4"
++ target="1.4"
+ />
+ </target>
+
+ <target name="jar" depends="compile">
+- <jar jarfile="jal-${version}.jar"
++ <jar jarfile="jal.jar"
+ basedir="${build}"
+ />
+ </target>
diff --git a/dev-java/jal/jal-20031117-r3.ebuild b/dev-java/jal/jal-20031117-r3.ebuild
new file mode 100644
index 000000000000..29882c675739
--- /dev/null
+++ b/dev-java/jal/jal-20031117-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Partial port of the C++ Standard Template Library"
+SRC_URI="http://vigna.dsi.unimi.it/jal/${P}-src.tar.gz"
+HOMEPAGE="http://vigna.dsi.unimi.it/jal/"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc source"
+
+RDEPEND=">=virtual/jre-1.4"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core
+ source? ( app-arch/zip )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/buildxml.patch
+
+ # we have to generate the sources first
+ ./instantiate -n byte bytes
+ ./instantiate -n short shorts
+ ./instantiate -n char chars
+ ./instantiate -n int ints
+ ./instantiate -n long longs
+ ./instantiate -n float floats
+ ./instantiate -n double doubles
+ ./instantiate Object objects
+ ./instantiate String strings
+ mkdir -p src/jal
+ mv bytes shorts chars ints longs floats doubles objects strings src/jal
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc "${S}"/src/jal
+}
diff --git a/dev-java/jal/metadata.xml b/dev-java/jal/metadata.xml
new file mode 100644
index 000000000000..182e3b1ada5b
--- /dev/null
+++ b/dev-java/jal/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+Jal is a partial port of the STL by the C++ Standard Template Library, done by
+Matthew Austern and Alexander Stepanov.
+
+It contains several useful algorithms that cannot be found elsewhere (e.g.,
+linear-time n-th order statistics and sorting arrays using arbitrary
+predicates).
+</longdescription>
+</pkgmetadata>