summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/junrar
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/junrar')
-rw-r--r--dev-java/junrar/Manifest1
-rw-r--r--dev-java/junrar/junrar-0.6.ebuild36
-rw-r--r--dev-java/junrar/metadata.xml8
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/junrar/Manifest b/dev-java/junrar/Manifest
new file mode 100644
index 000000000000..b2eefe5ea83b
--- /dev/null
+++ b/dev-java/junrar/Manifest
@@ -0,0 +1 @@
+DIST junrar-0.6.tar.gz 70631 SHA256 999c61f4cdbd0635acb3be2b36390e323f330988eb357c64cf47cf2a51b13721 SHA512 21da07fabb9f9c605191beaadad6a7abbdd1c02c8daab6913232889e735178954c0e2e7c4546734bb3b530d851d9016a549fbb68cc7795d005119fd176c15991 WHIRLPOOL 379bce7cfad99636fa4ecf8819fe02a6bea83845e6300af80f27c9dab871deb757e5817a49cd83ce1001b5d24350933a061b0af588dba04e609a518f1c2f4540
diff --git a/dev-java/junrar/junrar-0.6.ebuild b/dev-java/junrar/junrar-0.6.ebuild
new file mode 100644
index 000000000000..a416381f1a71
--- /dev/null
+++ b/dev-java/junrar/junrar-0.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source doc"
+
+inherit java-pkg-2 java-pkg-simple vcs-snapshot
+
+DESCRIPTION="Unrar java implementation"
+HOMEPAGE="https://github.com/edmund-wagner/junrar/"
+SRC_URI="https://github.com/edmund-wagner/${PN}/archive/${P}.tar.gz"
+
+LICENSE="unRAR"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="
+ dev-java/commons-logging:0
+ dev-java/commons-vfs:2"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.5"
+
+S="${WORKDIR}/${P}"
+
+JAVA_GENTOO_CLASSPATH="commons-logging,commons-vfs-2"
+JAVA_SRC_DIR="unrar/src/main/java"
+
+java_prepare() {
+ find -name "pom.xml" -delete || die
+}
diff --git a/dev-java/junrar/metadata.xml b/dev-java/junrar/metadata.xml
new file mode 100644
index 000000000000..d3985d9456c2
--- /dev/null
+++ b/dev-java/junrar/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="github">edmund-wagner/junrar</remote-id>
+ </upstream>
+</pkgmetadata>