summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-12-23 01:12:37 -0500
committerMichael Orlitzky <mjo@gentoo.org>2022-12-23 09:23:36 -0500
commit3371015e23a4c2fc0f6a8d566b80942c7bb15ed2 (patch)
tree4520d2b7e17dcf0da0de0f36d5de30540a77062a /dev-lang/R
parentnet-p2p/torrentinfo: Stabilize 1.8.6-r3 amd64, #888081 (diff)
downloadgentoo-3371015e23a4c2fc0f6a8d566b80942c7bb15ed2.tar.gz
gentoo-3371015e23a4c2fc0f6a8d566b80942c7bb15ed2.tar.bz2
gentoo-3371015e23a4c2fc0f6a8d566b80942c7bb15ed2.zip
dev-lang/R: add upstream patch to fix USE="-readline" build.
Closes: https://bugs.gentoo.org/883395 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/R-4.2.2.ebuild1
-rw-r--r--dev-lang/R/files/R-4.2.2-isspace-without-readline.patch22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-lang/R/R-4.2.2.ebuild b/dev-lang/R/R-4.2.2.ebuild
index f7daf9d87167..b1adfb0f9f9a 100644
--- a/dev-lang/R/R-4.2.2.ebuild
+++ b/dev-lang/R/R-4.2.2.ebuild
@@ -76,6 +76,7 @@ PATCHES=(
"${FILESDIR}"/R-3.6.2-no-LDFLAGS-in-libR-pkg-config.patch
"${FILESDIR}"/R-3.6.2-no-gzip-doc.patch
"${FILESDIR}"/R-4.2.2-browser-pdf-prefs.patch
+ "${FILESDIR}"/R-4.2.2-isspace-without-readline.patch
)
pkg_pretend() {
diff --git a/dev-lang/R/files/R-4.2.2-isspace-without-readline.patch b/dev-lang/R/files/R-4.2.2-isspace-without-readline.patch
new file mode 100644
index 000000000000..0b32bef1352b
--- /dev/null
+++ b/dev-lang/R/files/R-4.2.2-isspace-without-readline.patch
@@ -0,0 +1,22 @@
+From 6e36141598b78add7fb841480260b0a57ae79330 Mon Sep 17 00:00:00 2001
+From: smeyer <smeyer@00db46b3-68df-0310-9c12-caf00c1e9a41>
+Date: Wed, 26 Oct 2022 08:22:41 +0000
+Subject: [PATCH] avoid implicit declaration of 'isspace' --without-readline
+
+git-svn-id: https://svn.r-project.org/R/trunk@83178 00db46b3-68df-0310-9c12-caf00c1e9a41
+---
+ src/unix/sys-std.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/unix/sys-std.c b/src/unix/sys-std.c
+index 7b93d63884a..f95ff0cf7b3 100644
+--- a/src/unix/sys-std.c
++++ b/src/unix/sys-std.c
+@@ -1339,6 +1339,7 @@ Rstd_ShowFiles(int nfile, /* number of files */
+ */
+
+
++#include <ctype.h> /* for isspace */
+
+ int attribute_hidden Rstd_ChooseFile(int _new, char *buf, int len)
+ {