summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-04-19 21:40:08 +0200
committerTupone Alfredo <tupone@gentoo.org>2019-04-19 21:40:08 +0200
commit6037fa1f1074bcf0fa9ef762d58fc79ca4a2b915 (patch)
tree4716f075f894f5213b65b8f919ed4a848fae38c8 /dev-lang/gnat-gpl
parentsys-devel/llvm: Update binutils dep in 7.1.0 (diff)
downloadgentoo-6037fa1f1074bcf0fa9ef762d58fc79ca4a2b915.tar.gz
gentoo-6037fa1f1074bcf0fa9ef762d58fc79ca4a2b915.tar.bz2
gentoo-6037fa1f1074bcf0fa9ef762d58fc79ca4a2b915.zip
dev-lang/gnat-gpl: Fix missing ustat.h for gnat-gpl-2016
Signed-off-by: Alfredo Tupone <tupone@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-lang/gnat-gpl')
-rw-r--r--dev-lang/gnat-gpl/files/gnat-gpl-2016-ustat.patch31
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2016-r3.ebuild4
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-lang/gnat-gpl/files/gnat-gpl-2016-ustat.patch b/dev-lang/gnat-gpl/files/gnat-gpl-2016-ustat.patch
new file mode 100644
index 000000000000..ee0d22dcc9fd
--- /dev/null
+++ b/dev-lang/gnat-gpl/files/gnat-gpl-2016-ustat.patch
@@ -0,0 +1,31 @@
+--- a/gcc-4.9-gpl-2016-src/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc 2019-04-19 20:53:11.382114157 +0200
++++ b/gcc-4.9-gpl-2016-src/libsanitizer/sanitizer_common/sanitizer_platform_limits_posix.cc 2019-04-19 20:57:10.725037767 +0200
+@@ -81,7 +81,6 @@
+ #include <sys/statvfs.h>
+ #include <sys/timex.h>
+ #include <sys/user.h>
+-#include <sys/ustat.h>
+ #include <linux/cyclades.h>
+ #include <linux/if_eql.h>
+ #include <linux/if_plip.h>
+@@ -163,7 +162,19 @@
+ unsigned struct_old_utsname_sz = sizeof(struct old_utsname);
+ unsigned struct_oldold_utsname_sz = sizeof(struct oldold_utsname);
+ unsigned struct_itimerspec_sz = sizeof(struct itimerspec);
+- unsigned struct_ustat_sz = sizeof(struct ustat);
++ // Use pre-computed size of struct ustat to avoid <sys/ustat.h> which
++ // has been removed from glibc 2.28.
++#if defined(__aarch64__) || defined(__s390x__) || defined (__mips64) \
++ || defined(__powerpc64__) || defined(__arch64__) || defined(__sparcv9) \
++ || defined(__x86_64__)
++#define SIZEOF_STRUCT_USTAT 32
++#elif defined(__arm__) || defined(__i386__) || defined(__mips__) \
++ || defined(__powerpc__) || defined(__s390__) || defined(__sparc__)
++#define SIZEOF_STRUCT_USTAT 20
++#else
++#error Unknown size of struct ustat
++#endif
++ unsigned struct_ustat_sz = SIZEOF_STRUCT_USTAT;
+ #endif // SANITIZER_LINUX
+
+ #if SANITIZER_LINUX && !SANITIZER_ANDROID
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2016-r3.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2016-r3.ebuild
index b9eabc786360..86322c8996a0 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2016-r3.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2016-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -146,6 +146,8 @@ src_prepare() {
epatch "${FILESDIR}/${P}-finalization.patch"
# add profile for gnat_util compatibility
epatch "${FILESDIR}/${P}-profile.patch"
+ # fix missing ustat.h
+ epatch "${FILESDIR}/${P}-ustat.patch"
toolchain_src_prepare