summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Grigo <agrigo2001@yahoo.com.au>2020-11-27 22:14:55 +1100
committerJoonas Niilola <juippis@gentoo.org>2020-12-09 11:42:39 +0200
commit53cc01edc10416724da63affea4c44abc53c9360 (patch)
treeecb2c093f930600dd22a4f068f9c249af9056c0e /dev-lang/ispc
parentnet-analyzer/zabbix: introduce subslots (diff)
downloadgentoo-53cc01edc10416724da63affea4c44abc53c9360.tar.gz
gentoo-53cc01edc10416724da63affea4c44abc53c9360.tar.bz2
gentoo-53cc01edc10416724da63affea4c44abc53c9360.zip
dev-lang/ispc: Iscp only supports up to LLVM 10
Iscp does not yet have llvm 11 support, so limit clang and llvm in both ebuilds to version 10 maximum. Thanks to Toralf Förster, brothermechanic and Marco Genasci for their contributions to fixing this bug, I am only repackaging it. A working ispc is needed for adding embree support to blender. See https://github.com/ispc/ispc/issues/1896 Signed-off-by: Adrian Grigo <agrigo2001@yahoo.com.au> Closes: https://bugs.gentoo.org/749573 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/18427 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/ispc-1.14.1.ebuild14
-rw-r--r--dev-lang/ispc/ispc-9999.ebuild13
2 files changed, 17 insertions, 10 deletions
diff --git a/dev-lang/ispc/ispc-1.14.1.ebuild b/dev-lang/ispc/ispc-1.14.1.ebuild
index 58c0534cc5bf..0dd7a8767786 100644
--- a/dev-lang/ispc/ispc-1.14.1.ebuild
+++ b/dev-lang/ispc/ispc-1.14.1.ebuild
@@ -5,7 +5,9 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8,9} )
-inherit cmake toolchain-funcs python-any-r1
+inherit cmake toolchain-funcs python-any-r1 llvm
+
+LLVM_MAX_SLOT=10
DESCRIPTION="Intel SPMD Program Compiler"
HOMEPAGE="https://ispc.github.com/"
@@ -22,10 +24,8 @@ LICENSE="BSD BSD-2 UoI-NCSA"
SLOT="0"
IUSE="examples"
-RDEPEND="
- >=sys-devel/clang-3.0:*
- >=sys-devel/llvm-3.0:*
- "
+RDEPEND="<sys-devel/clang-11:="
+
DEPEND="
${RDEPEND}
${PYTHON_DEPS}
@@ -41,6 +41,10 @@ PATCHES=(
"${FILESDIR}/${PN}-1.13.0-werror.patch"
)
+llvm_check_deps() {
+ has_version -d "sys-devel/clang:${LLVM_SLOT}"
+}
+
src_prepare() {
if use amd64; then
# On amd64 systems, build system enables x86/i686 build too.
diff --git a/dev-lang/ispc/ispc-9999.ebuild b/dev-lang/ispc/ispc-9999.ebuild
index 07b62cdb24d2..6ccd5fef40af 100644
--- a/dev-lang/ispc/ispc-9999.ebuild
+++ b/dev-lang/ispc/ispc-9999.ebuild
@@ -5,7 +5,9 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8,9} )
-inherit cmake toolchain-funcs python-any-r1
+inherit cmake toolchain-funcs python-any-r1 llvm
+
+LLVM_MAX_SLOT=10
DESCRIPTION="Intel SPMD Program Compiler"
HOMEPAGE="https://ispc.github.com/"
@@ -22,10 +24,7 @@ LICENSE="BSD BSD-2 UoI-NCSA"
SLOT="0"
IUSE="examples"
-RDEPEND="
- >=sys-devel/clang-3.0:*
- >=sys-devel/llvm-3.0:*
- "
+RDEPEND="<sys-devel/clang-11:="
DEPEND="
${RDEPEND}
${PYTHON_DEPS}
@@ -41,6 +40,10 @@ PATCHES=(
"${FILESDIR}/${PN}-1.13.0-werror.patch"
)
+llvm_check_deps() {
+ has_version -d "sys-devel/clang:${LLVM_SLOT}"
+}
+
src_prepare() {
if use amd64; then
# On amd64 systems, build system enables x86/i686 build too.