summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-07-04 09:05:42 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-07-04 12:38:27 -0400
commit7d9685b45a751c82699682644d5a5203ce983888 (patch)
treef8a6dc9ea17a8bbd569fbf4edbe5939d3f1ee958 /dev-lang/php
parentnet-libs/meanwhile: add github remote-id (diff)
downloadgentoo-7d9685b45a751c82699682644d5a5203ce983888.tar.gz
gentoo-7d9685b45a751c82699682644d5a5203ce983888.tar.bz2
gentoo-7d9685b45a751c82699682644d5a5203ce983888.zip
dev-lang/php: temporarily(?) disable a few tests
Disable three failing tests that are being worked on upstream but will take a while to hit an official release. Closes: https://bugs.gentoo.org/935379 Closes: https://bugs.gentoo.org/935382 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/php-8.2.20.ebuild15
-rw-r--r--dev-lang/php/php-8.3.8.ebuild15
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-lang/php/php-8.2.20.ebuild b/dev-lang/php/php-8.2.20.ebuild
index d21e14874745..19bba50ac3f5 100644
--- a/dev-lang/php/php-8.2.20.ebuild
+++ b/dev-lang/php/php-8.2.20.ebuild
@@ -338,6 +338,21 @@ src_prepare() {
# https://github.com/php/php-src/issues/14368
#
rm ext/session/tests/gh13856.phpt || die
+
+ # Bug 935382, fixed eventually by
+ #
+ # - https://github.com/php/php-src/pull/14788
+ # - https://github.com/php/php-src/pull/14814
+ #
+ rm ext/standard/tests/strings/chunk_split_variation1_32bit.phpt || die
+ rm ext/standard/tests/strings/wordwrap_memory_limit.phpt || die
+
+ # Bug 935379, not yet fixed upstream but looks harmless (ordering
+ # of keys isn't guaranteed AFAICS):
+ #
+ # - https://github.com/php/php-src/issues/14786
+ #
+ rm ext/dba/tests/dba_gdbm.phpt || die
}
src_configure() {
diff --git a/dev-lang/php/php-8.3.8.ebuild b/dev-lang/php/php-8.3.8.ebuild
index 607ae090b3e6..8ea0dd1af24f 100644
--- a/dev-lang/php/php-8.3.8.ebuild
+++ b/dev-lang/php/php-8.3.8.ebuild
@@ -260,6 +260,21 @@ src_prepare() {
# https://github.com/php/php-src/issues/14368
#
rm ext/session/tests/gh13856.phpt || die
+
+ # Bug 935382, fixed eventually by
+ #
+ # - https://github.com/php/php-src/pull/14788
+ # - https://github.com/php/php-src/pull/14814
+ #
+ rm ext/standard/tests/strings/chunk_split_variation1_32bit.phpt || die
+ rm ext/standard/tests/strings/wordwrap_memory_limit.phpt || die
+
+ # Bug 935379, not yet fixed upstream but looks harmless (ordering
+ # of keys isn't guaranteed AFAICS):
+ #
+ # - https://github.com/php/php-src/issues/14786
+ #
+ rm ext/dba/tests/dba_gdbm.phpt || die
}
src_configure() {