summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-31 17:10:56 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-31 17:20:50 +0200
commit0b78548646bd14f22199e8c8f7ea7d98a41cdfcb (patch)
tree1c8b63fbe6b1b76f5007d604c6883532cbb06e1c /dev-lang
parentnet-wireless/blueman: Bump to 2.4.2 (diff)
downloadgentoo-0b78548646bd14f22199e8c8f7ea7d98a41cdfcb.tar.gz
gentoo-0b78548646bd14f22199e8c8f7ea7d98a41cdfcb.tar.bz2
gentoo-0b78548646bd14f22199e8c8f7ea7d98a41cdfcb.zip
dev-lang/python: Fix appending to COMMON_TEST_SKIPS
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.13.0_beta1_p3.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-lang/python/python-3.13.0_beta1_p3.ebuild b/dev-lang/python/python-3.13.0_beta1_p3.ebuild
index 1bc9c7f697f9..3744ca2daff1 100644
--- a/dev-lang/python/python-3.13.0_beta1_p3.ebuild
+++ b/dev-lang/python/python-3.13.0_beta1_p3.ebuild
@@ -252,7 +252,7 @@ src_configure() {
# Arch-specific skips. See #931888 for a collection of these.
case ${CHOST} in
alpha*)
- test_opts+=(
+ COMMON_TEST_SKIPS+=(
-x test_builtin
-x test_capi
-x test_cmath
@@ -269,30 +269,30 @@ src_configure() {
)
;;
ia64*)
- test_opts+=(
+ COMMON_TEST_SKIPS+=(
-x test_ctypes
-x test_external_inspection
)
;;
mips*)
- test_opts+=(
+ COMMON_TEST_SKIPS+=(
-x test_ctypes
-x test_external_inspection
-x test_statistics
)
;;
powerpc64-*) # big endian
- test_opts+=(
+ COMMON_TEST_SKIPS+=(
-x test_descr
)
;;
riscv*)
- test_opts+=(
+ COMMON_TEST_SKIPS+=(
-x test_urllib2
)
;;
sparc*)
- test_opts+=(
+ COMMON_TEST_SKIPS+=(
# bug 788022
-x test_multiprocessing_fork
-x test_multiprocessing_forkserver