summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-05-16 15:01:44 -0400
committerMichael Orlitzky <mjo@gentoo.org>2023-05-16 16:10:48 -0400
commitcc3a6140d83af5008f4d1671fb8198cd3ed63f18 (patch)
treed6287b1946f55f8e395d5df24946f17a6f5ac3b3 /dev-lang
parentprofiles/arch: mask USE=avif for dev-lang/php on a few arches. (diff)
downloadgentoo-cc3a6140d83af5008f4d1671fb8198cd3ed63f18.tar.gz
gentoo-cc3a6140d83af5008f4d1671fb8198cd3ed63f18.tar.bz2
gentoo-cc3a6140d83af5008f4d1671fb8198cd3ed63f18.zip
dev-lang/php: add support for USE=avif in php-8.1 and php-8.2.
This was originally a pull request by Henrik Alves that stalled. A follow-up bug reminded me to rebase the PR and apply it to php-8.2, but this is mostly Henrik's work. Thanks! Closes: https://bugs.gentoo.org/903728 Closes: https://github.com/gentoo/gentoo/pull/26588 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/metadata.xml3
-rw-r--r--dev-lang/php/php-8.1.18-r1.ebuild (renamed from dev-lang/php/php-8.1.18.ebuild)7
-rw-r--r--dev-lang/php/php-8.2.5-r1.ebuild (renamed from dev-lang/php/php-8.2.5.ebuild)7
3 files changed, 13 insertions, 4 deletions
diff --git a/dev-lang/php/metadata.xml b/dev-lang/php/metadata.xml
index 7143eef2004b..5783b3b852f7 100644
--- a/dev-lang/php/metadata.xml
+++ b/dev-lang/php/metadata.xml
@@ -17,6 +17,9 @@
<flag name="argon2">
Enable password hashing algorithm from <pkg>app-crypt/argon2</pkg>
</flag>
+ <flag name="avif">
+ Enable AVIF support in bundled libgd
+ </flag>
<flag name="bcmath">
Enable the BCMath Arbitrary Precision Mathematics extension
</flag>
diff --git a/dev-lang/php/php-8.1.18.ebuild b/dev-lang/php/php-8.1.18-r1.ebuild
index 7a0c8ba9fcf7..bdd36d3fc8f6 100644
--- a/dev-lang/php/php-8.1.18.ebuild
+++ b/dev-lang/php/php-8.1.18-r1.ebuild
@@ -33,8 +33,8 @@ IUSE="${IUSE}
${SAPIS/cli/+cli}
threads"
-IUSE="${IUSE} acl apparmor argon2 bcmath berkdb bzip2 calendar cdb cjk
- coverage +ctype curl debug
+IUSE="${IUSE} acl apparmor argon2 avif bcmath berkdb bzip2 calendar
+ cdb cjk coverage +ctype curl debug
enchant exif ffi +fileinfo +filter firebird
+flatfile ftp gd gdbm gmp +iconv imap inifile
intl iodbc ipv6 +jit kerberos ldap ldap-sasl libedit lmdb
@@ -49,6 +49,7 @@ IUSE="${IUSE} acl apparmor argon2 bcmath berkdb bzip2 calendar cdb cjk
# The Oracle instant client provides its own incompatible ldap library.
REQUIRED_USE="
|| ( cli cgi fpm apache2 embed phpdbg )
+ avif? ( gd zlib )
cli? ( ^^ ( readline libedit ) )
!cli? ( ?? ( readline libedit ) )
truetype? ( gd zlib )
@@ -82,6 +83,7 @@ COMMON_DEPEND="
fpm? ( acl? ( sys-apps/acl ) apparmor? ( sys-libs/libapparmor ) )
apache2? ( www-servers/apache[apache2_modules_unixd(+),threads=] )
argon2? ( app-crypt/argon2:= )
+ avif? ( media-libs/libavif:= )
berkdb? ( || ( sys-libs/db:5.3 sys-libs/db:4.8 ) )
bzip2? ( app-arch/bzip2:0= )
cdb? ( || ( dev-db/cdb dev-db/tinycdb ) )
@@ -262,6 +264,7 @@ src_configure() {
our_conf+=(
$(use_with apparmor fpm-apparmor)
$(use_with argon2 password-argon2 "${EPREFIX}/usr")
+ $(use_with avif)
$(use_enable bcmath)
$(use_with bzip2 bz2 "${EPREFIX}/usr")
$(use_enable calendar)
diff --git a/dev-lang/php/php-8.2.5.ebuild b/dev-lang/php/php-8.2.5-r1.ebuild
index d8e80841110d..7da6cd162462 100644
--- a/dev-lang/php/php-8.2.5.ebuild
+++ b/dev-lang/php/php-8.2.5-r1.ebuild
@@ -34,8 +34,8 @@ IUSE="${IUSE}
${SAPIS/cli/+cli}
threads"
-IUSE="${IUSE} acl apparmor argon2 bcmath berkdb bzip2 calendar cdb cjk
- coverage +ctype curl debug
+IUSE="${IUSE} acl apparmor argon2 avif bcmath berkdb bzip2 calendar
+ cdb cjk coverage +ctype curl debug
enchant exif ffi +fileinfo +filter firebird
+flatfile ftp gd gdbm gmp +iconv imap inifile
intl iodbc +jit kerberos ldap ldap-sasl libedit lmdb
@@ -50,6 +50,7 @@ IUSE="${IUSE} acl apparmor argon2 bcmath berkdb bzip2 calendar cdb cjk
# The Oracle instant client provides its own incompatible ldap library.
REQUIRED_USE="
|| ( cli cgi fpm apache2 embed phpdbg )
+ avif? ( gd zlib )
cli? ( ^^ ( readline libedit ) )
!cli? ( ?? ( readline libedit ) )
truetype? ( gd zlib )
@@ -83,6 +84,7 @@ COMMON_DEPEND="
fpm? ( acl? ( sys-apps/acl ) apparmor? ( sys-libs/libapparmor ) selinux? ( sys-libs/libselinux ) )
apache2? ( www-servers/apache[apache2_modules_unixd(+),threads=] )
argon2? ( app-crypt/argon2:= )
+ avif? ( media-libs/libavif:= )
berkdb? ( || ( sys-libs/db:5.3 sys-libs/db:4.8 ) )
bzip2? ( app-arch/bzip2:0= )
cdb? ( || ( dev-db/cdb dev-db/tinycdb ) )
@@ -264,6 +266,7 @@ src_configure() {
our_conf+=(
$(use_with apparmor fpm-apparmor)
$(use_with argon2 password-argon2 "${EPREFIX}/usr")
+ $(use_with avif)
$(use_enable bcmath)
$(use_with bzip2 bz2 "${EPREFIX}/usr")
$(use_enable calendar)