summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/beecrypt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/beecrypt')
-rw-r--r--dev-libs/beecrypt/Manifest1
-rw-r--r--dev-libs/beecrypt/beecrypt-4.2.1-r3.ebuild85
-rw-r--r--dev-libs/beecrypt/beecrypt-4.2.1.ebuild87
-rw-r--r--dev-libs/beecrypt/files/beecrypt-4.2.1-build-system.patch160
-rw-r--r--dev-libs/beecrypt/files/beecrypt-4.2.1-gcc-4.7.patch11
-rw-r--r--dev-libs/beecrypt/metadata.xml10
6 files changed, 354 insertions, 0 deletions
diff --git a/dev-libs/beecrypt/Manifest b/dev-libs/beecrypt/Manifest
new file mode 100644
index 000000000000..de57828f34db
--- /dev/null
+++ b/dev-libs/beecrypt/Manifest
@@ -0,0 +1 @@
+DIST beecrypt-4.2.1.tar.gz 882758 SHA256 286f1f56080d1a6b1d024003a5fa2158f4ff82cae0c6829d3c476a4b5898c55d SHA512 59995d53c024efe6344a21ac0d6d55fbe652488a4a22cc6719f9fc3851d56697fa8738937d48aa1e6f9ebe749de61ac3c79a5f0cea793872213c3bdf922e71bc WHIRLPOOL c4a0371d8e2cf37194800867c58e77d72bb59ab464fdff9c561230ece0f288dabdebfdd0ac13382c9ebe45b455ffbfdd81e6a15969dcb86d3d8c8e6635e294bb
diff --git a/dev-libs/beecrypt/beecrypt-4.2.1-r3.ebuild b/dev-libs/beecrypt/beecrypt-4.2.1-r3.ebuild
new file mode 100644
index 000000000000..6f011658724b
--- /dev/null
+++ b/dev-libs/beecrypt/beecrypt-4.2.1-r3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils multilib autotools java-pkg-opt-2 python-single-r1
+
+DESCRIPTION="general-purpose cryptography library"
+HOMEPAGE="http://sourceforge.net/projects/beecrypt/"
+SRC_URI="mirror://sourceforge/beecrypt/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos"
+IUSE="+threads java cxx python static-libs doc"
+
+COMMONDEPEND="!<app-arch/rpm-4.2.1
+ cxx? ( >=dev-libs/icu-2.8:= )
+ python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jdk-1.4 )
+ doc? ( app-doc/doxygen
+ virtual/latex-base
+ dev-texlive/texlive-fontsextra
+ )"
+RDEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jre-1.4 )"
+
+DOCS="BUGS README BENCHMARKS NEWS"
+
+REQUIRED_USE="cxx? ( threads )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ use java && java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+ java-pkg-opt-2_src_prepare
+
+ epatch "${FILESDIR}"/${P}-build-system.patch
+ epatch "${FILESDIR}"/${P}-gcc-4.7.patch
+ eautoreconf
+}
+
+src_configure() {
+ # cpluscplus needs threads support
+ econf \
+ --disable-expert-mode \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(use_with python python "${PYTHON}") \
+ $(use_with cxx cplusplus) \
+ $(use_with java)
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ cd include/beecrypt || die
+ doxygen || die "doxygen failed"
+ fi
+}
+
+src_test() {
+ export BEECRYPT_CONF_FILE="${T}/beecrypt-test.conf"
+ echo "provider.1=${S}/c++/provider/.libs/base.so" > "${BEECRYPT_CONF_FILE}"
+ emake check
+ emake bench
+}
+
+src_install() {
+ default
+ use python && rm -f "${D%/}$(python_get_sitedir)"/_bc.*a
+
+ use static-libs || find "${ED}" -name '*.la' -delete
+
+ use doc && dohtml -r docs/html/.
+}
diff --git a/dev-libs/beecrypt/beecrypt-4.2.1.ebuild b/dev-libs/beecrypt/beecrypt-4.2.1.ebuild
new file mode 100644
index 000000000000..794c132d3817
--- /dev/null
+++ b/dev-libs/beecrypt/beecrypt-4.2.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+PYTHON_DEPEND="python? 2"
+
+inherit eutils multilib autotools java-pkg-opt-2 python
+
+DESCRIPTION="general-purpose cryptography library"
+HOMEPAGE="http://sourceforge.net/projects/beecrypt/"
+SRC_URI="mirror://sourceforge/beecrypt/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="java cxx python static-libs threads doc"
+
+COMMONDEPEND="!<app-arch/rpm-4.2.1
+ cxx? ( >=dev-libs/icu-2.8 )"
+
+DEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jdk-1.4 )
+ doc? ( app-doc/doxygen
+ virtual/latex-base
+ dev-texlive/texlive-fontsextra
+ )"
+RDEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jre-1.4 )"
+
+DOCS="BUGS README BENCHMARKS NEWS"
+
+REQUIRED_USE="cxx? ( threads )"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ java-pkg-opt-2_pkg_setup
+ fi
+}
+
+src_prepare() {
+ java-pkg-opt-2_src_prepare
+
+ use python && python_convert_shebangs -r 2 .
+
+ epatch "${FILESDIR}"/${P}-build-system.patch
+ epatch "${FILESDIR}"/${P}-gcc-4.7.patch
+ eautoreconf
+}
+
+src_configure() {
+ # cpluscplus needs threads support
+ econf \
+ --disable-expert-mode \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(use_with python python "${EPREFIX}"/usr/bin/python2) \
+ $(use_with cxx cplusplus) \
+ $(use_with java)
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ cd include/beecrypt
+ doxygen || die "doxygen failed"
+ fi
+}
+
+src_test() {
+ export BEECRYPT_CONF_FILE="${T}/beecrypt-test.conf"
+ echo "provider.1=${S}/c++/provider/.libs/base.so" > "${BEECRYPT_CONF_FILE}"
+ emake check
+ emake bench
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/$(get_libdir)/python*/site-packages/_bc.*a
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+
+ use doc && dohtml -r docs/html/.
+}
diff --git a/dev-libs/beecrypt/files/beecrypt-4.2.1-build-system.patch b/dev-libs/beecrypt/files/beecrypt-4.2.1-build-system.patch
new file mode 100644
index 000000000000..e35095f53b6e
--- /dev/null
+++ b/dev-libs/beecrypt/files/beecrypt-4.2.1-build-system.patch
@@ -0,0 +1,160 @@
+--- beecrypt-4.2.1/configure.ac
++++ beecrypt-4.2.1/configure.ac
+@@ -11,7 +11,7 @@
+
+ # Checks for package options
+ AC_ARG_ENABLE(expert-mode, [ --enable-expert-mode follow user-defined CFLAGS settings [[default=no]]],[
+- ac_enable_expert_mode=yes
++ ac_enable_expert_mode=$enableval
+ ],[
+ if test "X$CFLAGS" != "X"; then
+ echo "enabling expert mode"
+@@ -25,7 +25,7 @@
+ if test "$ac_enable_expert_mode" = yes; then
+ AC_MSG_ERROR([--enable-debug cannot be used in conjunction with --enable-expert-mode])
+ fi
+- ac_enable_debug=yes
++ ac_enable_debug=$enableval
+ ],[
+ ac_enable_debug=no
+ ])
+@@ -456,7 +456,7 @@
+ ac_cv_python_include="-I`$PYTHON -c 'import distutils.sysconfig; print distutils.sysconfig.get_python_inc()'`"
+ ])
+ AC_CACHE_CHECK([where to install python libraries], ac_cv_python_libdir, [
+- ac_cv_python_libdir=`$PYTHON -c 'import distutils.sysconfig; print distutils.sysconfig.get_python_lib()'`
++ ac_cv_python_libdir=`$PYTHON -c 'import distutils.sysconfig; print distutils.sysconfig.get_python_lib(1, 0)'`
+ ])
+ fi
+ fi
+--- beecrypt-4.2.1/acinclude.m4
++++ beecrypt-4.2.1/acinclude.m4
+@@ -498,15 +498,6 @@ AC_DEFUN([BEE_GNU_CC],[
+ AC_SUBST(OPENMP_LIBS,"-lgomp")
+ fi
+ case $bc_target_arch in
+- x86_64 | athlon64 | athlon-fx | k8 | opteron | em64t | nocona)
+- CC="$CC -m64"
+- ;;
+- i[[3456]]86 | \
+- pentium* | \
+- athlon*)
+- CC="$CC -m32"
+- CCAS="$CCAS -m32"
+- ;;
+ ia64)
+ case $target_os in
+ # HP/UX on Itanium needs to be told that a long is 64-bit!
+@@ -525,17 +516,8 @@ AC_DEFUN([BEE_GNU_CC],[
+ aix*)
+ CC="$CC -maix64"
+ ;;
+- linux*)
+- CC="$CC -m64"
+- ;;
+ esac
+ ;;
+- sparc | sparcv8*)
+- CC="$CC -m32"
+- ;;
+- sparc64 | sparcv9*)
+- CC="$CC -m64"
+- ;;
+ esac
+ # Certain platforms needs special flags for multi-threaded code
+ if test "$ac_enable_threads" = yes; then
+@@ -646,14 +646,6 @@ dnl BEE_GNU_CXX
+ AC_DEFUN([BEE_GNU_CXX],[
+ AC_REQUIRE([AC_PROG_CXX])
+ case $bc_target_arch in
+- x86_64 | athlon64 | athlon-fx | k8 | opteron | em64t | nocona | core2)
+- CXX="$CXX -m64"
+- ;;
+- i[[3456]]86 | \
+- pentium* | \
+- athlon*)
+- CXX="$CXX -m32"
+- ;;
+ ia64)
+ case $target_os in
+ # HP/UX on Itanium needs to be told that a long is 64-bit!
+@@ -672,17 +664,8 @@ AC_DEFUN([BEE_GNU_CXX],[
+ aix*)
+ CXX="$CXX -maix64"
+ ;;
+- linux*)
+- CXX="$CXX -m64"
+- ;;
+ esac
+ ;;
+- sparc | sparcv8*)
+- CXX="$CXX -m32"
+- ;;
+- sparc64 | sparcv9*)
+- CXX="$CXX -m64"
+- ;;
+ esac
+ # Certain platforms needs special flags for multi-threaded code
+ if test "$ac_enable_threads" = yes; then
+--- beecrypt-4.2.1/java/Makefile.am
++++ beecrypt-4.2.1/java/Makefile.am
+@@ -26,7 +26,7 @@
+
+ INCLUDES = -I$(top_srcdir)/include
+
+-libaltdir=$(prefix)/lib@LIBALT@
++libaltdir=$(libdir)
+
+ libalt_LTLIBRARIES = libbeecrypt_java.la
+
+--- beecrypt-4.2.1/acinclude.m4
++++ beecrypt-4.2.1/acinclude.m4
+@@ -1589,20 +1589,5 @@
+ AC_SUBST(TYPEDEF_BC_THREADID_T,$bc_typedef_bc_threadid_t)
+ ])
+-
+-AH_BOTTOM([
+-#if ENABLE_THREADS
+-# ifndef _REENTRANT
+-# define _REENTRANT
+-# endif
+-# if LINUX
+-# define _LIBC_REENTRANT
+-# endif
+-#else
+-# ifdef _REENTRANT
+-# undef _REENTRANT
+-# endif
+-#endif
+-])
+
+
+ dnl BEE_THREAD_LOCAL_STORAGE
+@@ -1623,7 +1609,5 @@
+ ])
+
+ AH_BOTTOM([
+-#if !ENABLE_THREAD_LOCAL_STORAGE
+-# define __thread
+-#endif
++#include "config.threads.h"
+ ])
+--- beecrypt-4.2.1/config.threads.h
++++ beecrypt-4.2.1/config.threads.h
+@@ -0,0 +1,16 @@
++#if ENABLE_THREADS
++# ifndef _REENTRANT
++# define _REENTRANT
++# endif
++# if LINUX
++# define _LIBC_REENTRANT
++# endif
++#else
++# ifdef _REENTRANT
++# undef _REENTRANT
++# endif
++#endif
++
++#if !ENABLE_THREAD_LOCAL_STORAGE
++# define __thread
++#endif
diff --git a/dev-libs/beecrypt/files/beecrypt-4.2.1-gcc-4.7.patch b/dev-libs/beecrypt/files/beecrypt-4.2.1-gcc-4.7.patch
new file mode 100644
index 000000000000..64d513bde63f
--- /dev/null
+++ b/dev-libs/beecrypt/files/beecrypt-4.2.1-gcc-4.7.patch
@@ -0,0 +1,11 @@
+--- include/beecrypt/c++/util/AbstractSet.h
++++ include/beecrypt/c++/util/AbstractSet.h
+@@ -56,7 +56,7 @@
+ if (c->size() != size())
+ return false;
+
+- return containsAll(*c);
++ return this->containsAll(*c);
+ }
+ return false;
+ }
diff --git a/dev-libs/beecrypt/metadata.xml b/dev-libs/beecrypt/metadata.xml
new file mode 100644
index 000000000000..a8d32ea1a8a7
--- /dev/null
+++ b/dev-libs/beecrypt/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">beecrypt</remote-id>
+ </upstream>
+</pkgmetadata>