summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2016-06-01 21:51:22 +0300
committerSergey Popov <pinkbyte@gentoo.org>2016-06-01 21:51:22 +0300
commit0b0f9f37d0995be0bb173025f37e7e34bc45a5dc (patch)
tree29ea036e928e5fe10fd47cf6d858278191c1f15d /dev-libs/boost-numpy
parentdev-libs/boost-1.55.0-r1: Backport fix for python ABI letters (diff)
downloadgentoo-0b0f9f37d0995be0bb173025f37e7e34bc45a5dc.tar.gz
gentoo-0b0f9f37d0995be0bb173025f37e7e34bc45a5dc.tar.bz2
gentoo-0b0f9f37d0995be0bb173025f37e7e34bc45a5dc.zip
dev-libs/boost-numpy: update live ebuild
Bump EAPI to 6, use git-r3 and python-single-r1 eclasses. Add compatibility with new Python ABI naming. Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-libs/boost-numpy')
-rw-r--r--dev-libs/boost-numpy/boost-numpy-9999.ebuild26
1 files changed, 19 insertions, 7 deletions
diff --git a/dev-libs/boost-numpy/boost-numpy-9999.ebuild b/dev-libs/boost-numpy/boost-numpy-9999.ebuild
index 8a984c5c3c51..aef1918268ff 100644
--- a/dev-libs/boost-numpy/boost-numpy-9999.ebuild
+++ b/dev-libs/boost-numpy/boost-numpy-9999.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit cmake-utils
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit cmake-utils python-single-r1
DESCRIPTION="Boost.Python interface for NumPy"
HOMEPAGE="https://github.com/ndarray/Boost.NumPy"
if [ ${PV} == 9999 ]; then
- inherit git-2
+ inherit git-r3
EGIT_REPO_URI="git://github.com/ndarray/Boost.NumPy.git \
https://github.com/ndarray/Boost.NumPy.git"
else
@@ -18,14 +19,25 @@ fi
LICENSE="Boost-1.0"
SLOT=0
-IUSE="doc examples"
KEYWORDS=""
-CDEPEND="dev-python/numpy
- dev-libs/boost[python]"
+IUSE="doc examples"
+
+CDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ dev-libs/boost[python,${PYTHON_USEDEP}]"
DEPEND="${CDEPEND}"
RDEPEND="${CDEPEND}"
+src_prepare() {
+ # Make sure that new Python ABI names are searched too
+ sed -i \
+ -e 's/PythonLibsNew/PythonLibs/' \
+ -e 's/python3/python/' \
+ CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
src_install() {
cmake-utils_src_install