summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-04-28 17:12:57 +0200
committerSam James <sam@gentoo.org>2024-06-02 01:40:49 +0100
commit336a046ddd7db724ecd593b5d1e9ee9cdb01b4b4 (patch)
tree47ee989d88fc6441660adefa6bd4f46b5b795e72 /dev-libs/capstone
parentdev-libs/capstone: add missing RESTRICT (diff)
downloadgentoo-336a046ddd7db724ecd593b5d1e9ee9cdb01b4b4.tar.gz
gentoo-336a046ddd7db724ecd593b5d1e9ee9cdb01b4b4.tar.bz2
gentoo-336a046ddd7db724ecd593b5d1e9ee9cdb01b4b4.zip
dev-libs/capstone: drop 4.0.2-r2
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/36470 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/capstone')
-rw-r--r--dev-libs/capstone/Manifest1
-rw-r--r--dev-libs/capstone/capstone-4.0.2-r2.ebuild84
-rw-r--r--dev-libs/capstone/files/capstone-4.0.2-libsuffix.patch12
3 files changed, 0 insertions, 97 deletions
diff --git a/dev-libs/capstone/Manifest b/dev-libs/capstone/Manifest
index 3c41eeac7749..0262b03d1652 100644
--- a/dev-libs/capstone/Manifest
+++ b/dev-libs/capstone/Manifest
@@ -1,2 +1 @@
-DIST capstone-4.0.2.tar.gz 3439542 BLAKE2B 435729a8fef2dce6495635352101b3befe563c8404efdbb0dccabecbe2bded332221665bacdbcd9043dda72b652b6f29c0e1a548cefb8c64d5b6b9dc174ed3d9 SHA512 7f93534517307b737422a8825b66b2a1f3e1cca2049465d60ab12595940154aaf843ba40ed348fce58de58b990c19a0caef289060eb72898cb008a88c470970e
DIST capstone-5.0.1.tar.gz 7654195 BLAKE2B 83f6681d4c9c748df00daf59f7b33637ab72eee661261c22acae40a6db2def70bb6b5339d731244fdbae6f1e1b0b5b22bb6f60c1390a1bebceb97b3f810aedb0 SHA512 350aba77ce2d96b5c25764913591ba80e4497177ae0a8b2c820c6755ee8310848fbfc54e7ccac27fafc2dbc6778118ad92c53d1b5cb601d4fa146dec7d7e11e5
diff --git a/dev-libs/capstone/capstone-4.0.2-r2.ebuild b/dev-libs/capstone/capstone-4.0.2-r2.ebuild
deleted file mode 100644
index 579ef58d9929..000000000000
--- a/dev-libs/capstone/capstone-4.0.2-r2.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit cmake distutils-r1 toolchain-funcs
-
-DESCRIPTION="disassembly/disassembler framework + bindings"
-HOMEPAGE="https://www.capstone-engine.org/"
-SRC_URI="https://github.com/capstone-engine/capstone/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/4" # libcapstone.so.4
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-# A few disassembly outputs need an update
-RESTRICT="test"
-
-IUSE="python static-libs test"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
- python? ( dev-python/setuptools[${PYTHON_USEDEP}] )
-"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-#TODO: needs upstream fixes
-#distutils_enable_tests setup.py
-
-S=${WORKDIR}/${P/_rc/-rc}
-
-PATCHES=(
- "${FILESDIR}"/${P}-libsuffix.patch
-)
-
-wrap_python() {
- local phase=$1
- shift
-
- if use python; then
- pushd bindings/python >/dev/null || die
- echo distutils-r1_${phase} "$@"
- pwd
- distutils-r1_${phase} "$@"
- popd >/dev/null
- fi
-}
-
-src_prepare() {
- tc-export RANLIB
- cmake_src_prepare
-
- wrap_python ${FUNCNAME}
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCAPSTONE_BUILD_TESTS="$(usex test)"
- -DCAPSTONE_BUILD_STATIC="$(usex static-libs)"
- )
- cmake_src_configure
-
- wrap_python ${FUNCNAME}
-}
-
-src_compile() {
- cmake_src_compile
-
- wrap_python ${FUNCNAME}
-}
-
-src_test() {
- cmake_src_test
-
- wrap_python ${FUNCNAME}
-}
-
-src_install() {
- cmake_src_install
-
- wrap_python ${FUNCNAME}
-}
diff --git a/dev-libs/capstone/files/capstone-4.0.2-libsuffix.patch b/dev-libs/capstone/files/capstone-4.0.2-libsuffix.patch
deleted file mode 100644
index 056140be13df..000000000000
--- a/dev-libs/capstone/files/capstone-4.0.2-libsuffix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-cmake does not provide 'LIBSUFFIX' variables, but provides 'LIB_SUFFIX'.
-https://bugs.gentoo.org/730722
---- a/capstone.pc.in
-+++ b/capstone.pc.in
-@@ -1,6 +1,6 @@
- prefix=@CMAKE_INSTALL_PREFIX@
- exec_prefix=${prefix}
--libdir=${prefix}/lib@LIBSUFFIX@
-+libdir=${prefix}/@CMAKE_INSTALL_LIBDIR@
- includedir=${prefix}/include/capstone
-
- Name: capstone