summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-15 03:55:30 +0100
committerSam James <sam@gentoo.org>2021-04-16 12:15:34 +0100
commitd6dc40321f7fe66d418d5a1e5e1f29718514e766 (patch)
treeabc91e2e7db5891d41e0a7de3f2353f87443a06e /dev-libs/go-fuse
parentdev-libs/ffcall: eutils--, toolchain-funcs-- (diff)
downloadgentoo-d6dc40321f7fe66d418d5a1e5e1f29718514e766.tar.gz
gentoo-d6dc40321f7fe66d418d5a1e5e1f29718514e766.tar.bz2
gentoo-d6dc40321f7fe66d418d5a1e5e1f29718514e766.zip
dev-libs/go-fuse: eutils--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/go-fuse')
-rw-r--r--dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild11
-rw-r--r--dev-libs/go-fuse/go-fuse-0_p20150422.ebuild8
-rw-r--r--dev-libs/go-fuse/go-fuse-9999.ebuild24
3 files changed, 18 insertions, 25 deletions
diff --git a/dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild b/dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild
index b962c085f6b5..0ff5a2228922 100644
--- a/dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild
+++ b/dev-libs/go-fuse/go-fuse-0_p20140812-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit eutils vcs-clean
+inherit vcs-clean
GO_PN=github.com/hanwen/${PN}
EGIT_COMMIT="8c85ded140ac1889372a0e22d8d21e3d10a303bd"
@@ -11,19 +11,16 @@ EGIT_COMMIT="8c85ded140ac1889372a0e22d8d21e3d10a303bd"
HOMEPAGE="https://github.com/hanwen/go-fuse"
DESCRIPTION="FUSE bindings for Go"
SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"
-SLOT="0"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
DEPEND=">=dev-lang/go-1.3"
-RDEPEND=""
RESTRICT="strip"
-S=${WORKDIR}
-
src_unpack() {
default_src_unpack
mkdir -p src/${GO_PN%/*} || die
diff --git a/dev-libs/go-fuse/go-fuse-0_p20150422.ebuild b/dev-libs/go-fuse/go-fuse-0_p20150422.ebuild
index d432b751b899..2a069dc0c67c 100644
--- a/dev-libs/go-fuse/go-fuse-0_p20150422.ebuild
+++ b/dev-libs/go-fuse/go-fuse-0_p20150422.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit eutils vcs-clean
+inherit vcs-clean
GO_PN=github.com/hanwen/${PN}
EGIT_COMMIT="ffed29ec8b88f61c1b8954134cc48ef03bb26ce1"
@@ -12,13 +12,11 @@ HOMEPAGE="https://github.com/hanwen/go-fuse"
DESCRIPTION="FUSE bindings for Go"
SRC_URI="https://${GO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-SLOT="0"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
DEPEND=">=dev-lang/go-1.3"
-RDEPEND=""
RESTRICT="strip"
diff --git a/dev-libs/go-fuse/go-fuse-9999.ebuild b/dev-libs/go-fuse/go-fuse-9999.ebuild
index 6e408999381f..a745fe10ed3a 100644
--- a/dev-libs/go-fuse/go-fuse-9999.ebuild
+++ b/dev-libs/go-fuse/go-fuse-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -11,11 +11,8 @@ EGIT_REPO_URI="https://github.com/hanwen/go-fuse.git"
LICENSE="BSD"
SLOT="0"
-KEYWORDS=""
-IUSE=""
DEPEND=">=dev-lang/go-1.3"
-RDEPEND=""
RESTRICT="strip"
@@ -26,12 +23,12 @@ export GOPATH="${S}"
src_compile() {
local d
-#no examples right now
-# example/hello example/loopback example/zipfs \
-# example/multizip example/unionfs example/memfs \
-# example/autounionfs ; \
-#or tests
-#fuse/test
+ #no examples right now
+ # example/hello example/loopback example/zipfs \
+ # example/multizip example/unionfs example/memfs \
+ # example/autounionfs ; \
+ #or tests
+ #fuse/test
for d in fuse fuse/pathfs zipfs unionfs; do
go build -v -x -work ${GO_PN}/${d} || die
done
@@ -46,9 +43,10 @@ src_install() {
insinto /usr/lib/go/
doins -r "${S}/pkg"
insinto "/usr/lib/go/src/${GO_PN}/"
- #for this ebuild, to fix bug #503324 I have limited what is installed
- #another possible solution would have been using adddeny to the
- #hide installed filed during build
+
+ # for this ebuild, to fix bug #503324 I have limited what is installed
+ # another possible solution would have been using adddeny to the
+ # hide installed filed during build
egit_clean "${S}/src/${GO_PN}"
doins -r "${S}/src/${GO_PN}/fuse"
doins -r "${S}/src/${GO_PN}/splice"