summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-02-24 15:27:12 +0100
committerPacho Ramos <pacho@gentoo.org>2023-02-24 15:27:12 +0100
commit707f9697851dad4b11f1c67a1502789f8293b4cb (patch)
tree321e93a177594c7c6bdeee16996dac2a6e7ff08a /dev-libs/libmcfp/libmcfp-1.2.3.ebuild
parentdev-libs/libayatana-appindicator: add 0.5.92 (diff)
downloadgentoo-707f9697851dad4b11f1c67a1502789f8293b4cb.tar.gz
gentoo-707f9697851dad4b11f1c67a1502789f8293b4cb.tar.bz2
gentoo-707f9697851dad4b11f1c67a1502789f8293b4cb.zip
dev-libs/libmcfp: add 1.2.3
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-libs/libmcfp/libmcfp-1.2.3.ebuild')
-rw-r--r--dev-libs/libmcfp/libmcfp-1.2.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/libmcfp/libmcfp-1.2.3.ebuild b/dev-libs/libmcfp/libmcfp-1.2.3.ebuild
new file mode 100644
index 000000000000..39c57dc4f1bf
--- /dev/null
+++ b/dev-libs/libmcfp/libmcfp-1.2.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="A library that can collect configuration options from command line arguments"
+HOMEPAGE="https://github.com/mhekkel/libmcfp"
+SRC_URI="https://github.com/mhekkel/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTING="$(usex test)"
+ )
+ cmake_src_configure
+}