summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-09-07 15:32:31 +0200
committerPacho Ramos <pacho@gentoo.org>2021-09-07 16:08:36 +0200
commitbd9b8593b59f3b7a85a1f6bf62fcc95e8a27f359 (patch)
tree18c0720280e69e4c76e4dca85859537385d4366e /dev-libs/libwacom
parentprofiles: Mask net-libs/gsnmp for removal (diff)
downloadgentoo-bd9b8593b59f3b7a85a1f6bf62fcc95e8a27f359.tar.gz
gentoo-bd9b8593b59f3b7a85a1f6bf62fcc95e8a27f359.tar.bz2
gentoo-bd9b8593b59f3b7a85a1f6bf62fcc95e8a27f359.zip
dev-libs/libwacom: Bump to 1.12
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-libs/libwacom')
-rw-r--r--dev-libs/libwacom/Manifest1
-rw-r--r--dev-libs/libwacom/libwacom-1.12.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/libwacom/Manifest b/dev-libs/libwacom/Manifest
index 535d4d0b99fd..0960301449ea 100644
--- a/dev-libs/libwacom/Manifest
+++ b/dev-libs/libwacom/Manifest
@@ -1 +1,2 @@
DIST libwacom-1.11.tar.bz2 519285 BLAKE2B fb26190d752316b5d25659d2ae76681bfff1803463360aa138eab91ed7d7ef2d04dfb6bdd4f8c2effc45a495ef3afc312a817d4fd41cd8167172cafd9f5cee9f SHA512 24e8183502dd2b928d53b3d26d8479210e855c94c225649d63ac33062a30615654ff0ab8666a25503fb3253125539cd845ca467fb228a01c608dc3adbbec73b5
+DIST libwacom-1.12.tar.bz2 543819 BLAKE2B fdbfba23d7b1e047757b0c0ff698a484cadc91c199459e1da49bfd5a5406aeb62d2ca43856f7d8363c3f36c7c05f4d3160e8fb576c3d18f085144dec259d49c5 SHA512 4e0084eda01e78f52336f3f1f1ea3ea86cb9c5fdd6d6c0316662405ebe2a328d6837f8db855e58f5fa95a640a5d456a081a7de339a372bf851bc0d5c69530379
diff --git a/dev-libs/libwacom/libwacom-1.12.ebuild b/dev-libs/libwacom/libwacom-1.12.ebuild
new file mode 100644
index 000000000000..de40b8c9ca0d
--- /dev/null
+++ b/dev-libs/libwacom/libwacom-1.12.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit meson python-any-r1 toolchain-funcs udev
+
+DESCRIPTION="Library for identifying Wacom tablets and their model-specific features"
+HOMEPAGE="https://github.com/linuxwacom/libwacom"
+SRC_URI="https://github.com/linuxwacom/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libgudev:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/python-libevdev[${PYTHON_USEDEP}]
+ dev-python/pyudev[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ has_version -b "dev-python/python-libevdev[${PYTHON_USEDEP}]" &&
+ has_version -b "dev-python/pyudev[${PYTHON_USEDEP}]" &&
+ has_version -b "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ tc-ld-disable-gold # bug https://github.com/linuxwacom/libwacom/issues/170
+
+ if use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature doc documentation)
+ $(meson_feature test tests)
+ -Dudev-dir=$(get_udevdir)
+ )
+ meson_src_configure
+}