summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/pugixml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/pugixml')
-rw-r--r--dev-libs/pugixml/Manifest2
-rw-r--r--dev-libs/pugixml/metadata.xml8
-rw-r--r--dev-libs/pugixml/pugixml-1.5.ebuild22
-rw-r--r--dev-libs/pugixml/pugixml-1.6.ebuild22
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/pugixml/Manifest b/dev-libs/pugixml/Manifest
new file mode 100644
index 000000000000..3e0bb498fab5
--- /dev/null
+++ b/dev-libs/pugixml/Manifest
@@ -0,0 +1,2 @@
+DIST pugixml-1.5.tar.gz 374783 SHA256 d70b98002968d9431e4166e6a76486a6d346eb9a76d1a0e7be58e786d3dee670 SHA512 9d9098fa7a28d64d970f9afaffa088b94dbd9845a985fe78bc537870b7bdc170980b429b34d3044779d0674972dbe1ef54d26d17e6294f985a72889409359f54 WHIRLPOOL 0ba3a11a246d8dca60366874a68078691a4840ae37a1a0432ba8f8a95e77e4a65e1da42b48e8a44781a15ffb855f78bfafe91167886b3ebea202b028b4ce720f
+DIST pugixml-1.6.tar.gz 346616 SHA256 473705c496d45ee6a74f73622b175dfb5dde0de372c4dc61a5acb964516cd9de SHA512 9f5be170902af9a9ba4911d34e584ee83ccdea1c9ce6092e67c9180ce42ae313739aa091bb0e370f813753aafad653264ea0b3d8623d207429fa779f5576c70f WHIRLPOOL 0b3196320739f939de538bc0f13dfc7ddae7aff502c55b3933c74e35fb4c7c18a63ca99441a77c0c676bead2885cdf04f373b9fe04f5281e1769c89a764206f5
diff --git a/dev-libs/pugixml/metadata.xml b/dev-libs/pugixml/metadata.xml
new file mode 100644
index 000000000000..ec127a995bb0
--- /dev/null
+++ b/dev-libs/pugixml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <upstream>
+ <remote-id type="github">zeux/pugixml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/pugixml/pugixml-1.5.ebuild b/dev-libs/pugixml/pugixml-1.5.ebuild
new file mode 100644
index 000000000000..d670731df255
--- /dev/null
+++ b/dev-libs/pugixml/pugixml-1.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
+HOMEPAGE="http://pugixml.org/ https://github.com/zeux/pugixml/"
+SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+S=${WORKDIR}/${P}/scripts
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=ON )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/pugixml/pugixml-1.6.ebuild b/dev-libs/pugixml/pugixml-1.6.ebuild
new file mode 100644
index 000000000000..2b07f83f4314
--- /dev/null
+++ b/dev-libs/pugixml/pugixml-1.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Light-weight, simple, and fast XML parser for C++ with XPath support"
+HOMEPAGE="http://pugixml.org/ https://github.com/zeux/pugixml/"
+SRC_URI="https://github.com/zeux/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+S=${WORKDIR}/${P}/scripts
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=ON )
+ cmake-utils_src_configure
+}