summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-10-18 18:25:05 -0400
committerAnthony G. Basile <blueness@gentoo.org>2017-10-18 19:05:06 -0400
commita738a157a2c471e1b70028d9417205491baa74b9 (patch)
treea978ec42dff09df7bd8b34360892b6a12488c0d8 /dev-libs/xapian
parentdev-perl/Crypt-DES: EAPI6 + Test love (diff)
downloadgentoo-a738a157a2c471e1b70028d9417205491baa74b9.tar.gz
gentoo-a738a157a2c471e1b70028d9417205491baa74b9.tar.bz2
gentoo-a738a157a2c471e1b70028d9417205491baa74b9.zip
dev-libs/xapian: version bump to 1.4.5
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-libs/xapian')
-rw-r--r--dev-libs/xapian/Manifest1
-rw-r--r--dev-libs/xapian/xapian-1.4.5.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-libs/xapian/Manifest b/dev-libs/xapian/Manifest
index b9b909f3d22a..562506305616 100644
--- a/dev-libs/xapian/Manifest
+++ b/dev-libs/xapian/Manifest
@@ -2,3 +2,4 @@ DIST xapian-core-1.2.22.tar.xz 3204096 SHA256 269b87ca3faf79d444e8bb82ed58a96f19
DIST xapian-core-1.2.24.tar.xz 3210192 SHA256 57a82717ba07e9777958b6ef48d94b81ea41ac4c74d544f74da597fab1e1f87b SHA512 1f8ae5848f94b5f0bee03024f12ae8c336b6d85e58f7b36e885fe604f9fb962c0525e1f44e6cfcd183e811226c61b23f0f2fcc35c7d2e63544b19347a0f96c80 WHIRLPOOL fef6db7f393d4563828e1650eecd02e30d37f5837042b6a8992cfddb962593675f9c3af4eb5d387db71f99468235905bdbe5666f91975b260cb649fd422425ae
DIST xapian-core-1.2.25.tar.xz 3253292 SHA256 7c77ff259bc92414c620015d6798f5f3e2c52907936096ec97c23c17fc0d6403 SHA512 a15b5d9b5770337519f671732f53f0642b31f08206824500d589ba309c9e91a05a30353d66ebf70a4c1cb1824b44e1c7b7630e799de3b15d645cf951a6017bfe WHIRLPOOL 6b6335fcf2beff23930ea20822fdd1251307d095f09424b36734a9ba001cecbf7398d525022c37b1d8b8d7d612f509946469dcbacc207cd51e68ce8bb75ce3d1
DIST xapian-core-1.4.4.tar.xz 2807952 SHA256 a6a985a9841a452d75cf2169196b7ca6ebeef27da7c607078cd401ad041732d9 SHA512 dc88bab1d82c68b29d51c2113319ddb5d16840f3544b9d5fcc7a3671f97d58f16ddff58b865ad3521ea778cbaacf73fe7346bb514a1275f1f739283a4128d001 WHIRLPOOL f1b89b0a5ad47111eb4fe068a5aee29033b694fdd6405041972ebfcc81333662ce74bfc0251a37be9a0d04d7cc232681173e1443840277eedac814b46d9bc728
+DIST xapian-core-1.4.5.tar.xz 2810612 SHA256 85b5f952de9df925fd13e00f6e82484162fd506d38745613a50b0a2064c6b02b SHA512 cff97a856a406583ca81164ddb704a0eeae7d8d6f94ce3b3f53d5208d657423e87dd06bdc7acb5e5904765bce1cefbc98365cde315c1d46f7b18cfba7b022ae6 WHIRLPOOL 287fa5a952a492da4b9f00a43e32474e40a0d6b3efc0c7585e5842f0f3d219aa87c0c29561d1ee0dd77db680e6f2bc2b755ac4a140c8b7e4bde63ff62717165c
diff --git a/dev-libs/xapian/xapian-1.4.5.ebuild b/dev-libs/xapian/xapian-1.4.5.ebuild
new file mode 100644
index 000000000000..923b057a6bef
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.4.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils multilib-minimal
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/30" # ABI version of libxapian.so
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x64-solaris"
+IUSE="doc static-libs -cpu_flags_x86_sse +cpu_flags_x86_sse2 +glass +chert +inmemory"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="inmemory? ( chert )"
+
+S="${WORKDIR}/${MY_P}"
+
+multilib_src_configure() {
+ local myconf=""
+
+ if use cpu_flags_x86_sse2; then
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use cpu_flags_x86_sse; then
+ myconf="${myconf} --enable-sse=sse"
+ else
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use glass || myconf="${myconf} --disable-backend-glass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+
+ myconf="${myconf} --enable-backend-remote --program-suffix="
+
+ ECONF_SOURCE=${S} econf $myconf
+}
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/xapian/postingsource.h
+ /usr/include/xapian/attributes.h
+ /usr/include/xapian/valuesetmatchdecider.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/version.h
+ /usr/include/xapian/types.h
+ /usr/include/xapian/positioniterator.h
+ /usr/include/xapian/registry.h
+)
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ # bug #573466
+ ln -sf "${D}usr/bin/xapian-config" "${D}usr/bin/xapian-config-1.3"
+
+ use doc || rm -rf "${D}usr/share/doc/xapian-core-${PV}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+
+ prune_libtool_files --all
+}
+
+multilib_src_test() {
+ emake check VALGRIND=
+}