summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2021-09-24 13:08:03 -0400
committerAnthony G. Basile <blueness@gentoo.org>2021-09-24 13:08:38 -0400
commit947a1f683d232d56ec58391c4dadcf0e656e12b9 (patch)
tree595a593a40d3648ca1bc63a4ccf02317608ad56a /dev-libs
parentdev-ruby/puppetdb-termini: 7.4.1 cleanup (diff)
downloadgentoo-947a1f683d232d56ec58391c4dadcf0e656e12b9.tar.gz
gentoo-947a1f683d232d56ec58391c4dadcf0e656e12b9.tar.bz2
gentoo-947a1f683d232d56ec58391c4dadcf0e656e12b9.zip
dev-libs/libgpiod: version bump to 1.6.3
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgpiod/Manifest1
-rw-r--r--dev-libs/libgpiod/libgpiod-1.6.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/libgpiod/Manifest b/dev-libs/libgpiod/Manifest
index 96b415fe2406..703fe10fabe0 100644
--- a/dev-libs/libgpiod/Manifest
+++ b/dev-libs/libgpiod/Manifest
@@ -1,2 +1,3 @@
DIST libgpiod-1.1.1.tar.xz 302672 BLAKE2B 71c624f923118b7c50970beb737f2c813d1470a34f95798f9ce821211e16f15e2a3fd42d0054e25529ddc9846725c0935d915784f22d2509b844a0bac61b66b6 SHA512 a1d902ce8e1c94d5550ade2fb4889ebe28b86523505b92ab907f58c8e6903eaf07ce16278126989462956b879f591b42ddd50fbc4537c1b5af459f23a4dfc12f
DIST libgpiod-1.4.1.tar.xz 314936 BLAKE2B 8949c4a96f69a83a479f5951e6f1eb8fee56db700e72320131c365a5d736a48700fb42b7ecc2b676cec54887eaa650075f45ec1f0b803de914958cefd3863db8 SHA512 2a9c58a46fb3c2e2dd15cc4ba52f589b44e5ae4547226eeb68a8e5bea6292d38aaf0889cc639e0979e12e129bb944bb42d9258f10292f59d074660e7c2d56d04
+DIST libgpiod-1.6.3.tar.xz 326068 BLAKE2B eda5409f2db3914ede92690589643211eca3002f8dc53a7c48213602f28158084c8eb8061319923f7a51c7d91650ff58b81b059323b5b9133a28b0bb04f6904d SHA512 f7e48662d02904f3f25976d61aa2cf4af0b8a52f65f184f23dfb6916bde9b86634b211f2696d3459a4f902ba5a79621b2fc47d18d487fd7a159018fe8933e370
diff --git a/dev-libs/libgpiod/libgpiod-1.6.3.ebuild b/dev-libs/libgpiod/libgpiod-1.6.3.ebuild
new file mode 100644
index 000000000000..8f3fe8c74ec2
--- /dev/null
+++ b/dev-libs/libgpiod/libgpiod-1.6.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="C library and tools for interacting with the linux GPIO character device"
+HOMEPAGE="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
+SRC_URI="https://mirrors.edge.kernel.org/pub/software/libs/libgpiod/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+# Reflects the ABI of libgpiod.so
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="static-libs +tools cxx python test"
+RESTRICT="!test? ( test )"
+
+# --enable-tests enable libgpiod tests [default=no]
+# --enable-bindings-cxx enable C++ bindings [default=no]
+# --enable-bindings-python
+
+multilib_src_configure() {
+ local myconf=(
+ $(use_enable tools)
+ $(use_enable cxx bindings-cxx)
+ $(use_enable test tests)
+ $(multilib_native_use_enable python bindings-python)
+ )
+
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ --disable-tools
+ )
+ fi
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_install() {
+ default
+
+ find "${D}" -name '*.la' -type f -delete || die
+
+ if ! use static-libs; then
+ find "${D}" -name "*.a" -delete || die
+ fi
+}