summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-02-17 23:29:52 +0600
committerAndrey Grozin <grozin@gentoo.org>2016-02-17 23:29:52 +0600
commit537acbec9ddd8856a4c226b5c032e3bafcf3da31 (patch)
tree89a261f52975d3d74a073d1ab79e701c982ad3f4 /dev-lisp/gcl
parentdev-libs/starpu: removed old (diff)
downloadgentoo-537acbec9ddd8856a4c226b5c032e3bafcf3da31.tar.gz
gentoo-537acbec9ddd8856a4c226b5c032e3bafcf3da31.tar.bz2
gentoo-537acbec9ddd8856a4c226b5c032e3bafcf3da31.zip
dev-lisp/gcl: 2.6.12 now uilds with gcc-5
Bug: 574652 Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-lisp/gcl')
-rw-r--r--dev-lisp/gcl/files/gcl-2.6.12-gcc5.patch8
-rw-r--r--dev-lisp/gcl/gcl-2.6.12.ebuild4
2 files changed, 11 insertions, 1 deletions
diff --git a/dev-lisp/gcl/files/gcl-2.6.12-gcc5.patch b/dev-lisp/gcl/files/gcl-2.6.12-gcc5.patch
new file mode 100644
index 000000000000..07d3892eb0b6
--- /dev/null
+++ b/dev-lisp/gcl/files/gcl-2.6.12-gcc5.patch
@@ -0,0 +1,8 @@
+diff -r -U1 gcl.orig/makefile gcl/makefile
+--- gcl.orig/makefile 2014-10-23 23:29:00.000000000 +0200
++++ gcl/makefile 2016-02-17 18:10:29.871808118 +0100
+@@ -267,3 +267,3 @@
+ $(AWK) 'BEGIN {print "#include \"include.h\"";print "#include \"cmponly.h\"";print "---"} {a=$$1;gsub("\\.\\.\\.","",a);print "\"#define " $$1 "\" " a}' $< |\
+- $(CC) -E -I./$(HDIR) - |\
++ $(CC) -E -P -I./$(HDIR) - |\
+ $(AWK) '/^\-\-\-$$/ {i=1;next} {if (!i) next} {gsub("\"","");print}' >$@
diff --git a/dev-lisp/gcl/gcl-2.6.12.ebuild b/dev-lisp/gcl/gcl-2.6.12.ebuild
index 11e8275ba21b..959c2692a57b 100644
--- a/dev-lisp/gcl/gcl-2.6.12.ebuild
+++ b/dev-lisp/gcl/gcl-2.6.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -38,6 +38,7 @@ src_prepare() {
chmod a+x add-defs add-defs1 config.guess config.sub configure install.sh
chmod a+x bin/info bin/info1 gcl-tk/gcltksrv.in gcl-tk/ngcltksrv mp/gcclab
chmod a+x o/egrep-def utils/replace xbin/*
+ epatch "${FILESDIR}"/${P}-gcc5.patch
# fedora patches
epatch "${WORKDIR}"/fedora/fd-leak.patch
@@ -62,6 +63,7 @@ src_prepare() {
src_configure() {
strip-flags
filter-flags -fstack-protector -fstack-protector-all
+ append-cflags $(test-flags-CC -fgnu89-inline)
local tcl=""
if use tk; then