summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-30 12:39:05 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-30 14:32:43 +0100
commit81283ca1559dd87603e9da0b06b6520101afba88 (patch)
treed05bfd39a8d53ad77f23745c5591e15653adaaf7 /dev-lua/busted
parentmail-mta/protonmail-bridge-bin: add self as co-maintainer (diff)
downloadgentoo-81283ca1559dd87603e9da0b06b6520101afba88.tar.gz
gentoo-81283ca1559dd87603e9da0b06b6520101afba88.tar.bz2
gentoo-81283ca1559dd87603e9da0b06b6520101afba88.zip
dev-lua/busted: remove lua deps version requirement
The LUA_USEDEP bit is sufficient to pull in a version migrated to Lua eclasses, regardless of whether either of these gets updated to a new release before we unmask slotted Lua or not. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/busted')
-rw-r--r--dev-lua/busted/busted-2.0.0-r101.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/dev-lua/busted/busted-2.0.0-r101.ebuild b/dev-lua/busted/busted-2.0.0-r101.ebuild
index 22652c4ffdfc..4ccbce376e4f 100644
--- a/dev-lua/busted/busted-2.0.0-r101.ebuild
+++ b/dev-lua/busted/busted-2.0.0-r101.ebuild
@@ -19,15 +19,15 @@ REQUIRED_USE="${LUA_REQUIRED_USE}"
RESTRICT="!test? ( test )"
RDEPEND="
- >=dev-lua/lua_cliargs-3.0_p2-r100[${LUA_USEDEP}]
- >=dev-lua/luafilesystem-1.8.0-r100[${LUA_USEDEP}]
- >=dev-lua/luasystem-0.2.1_p0-r100[${LUA_USEDEP}]
- >=dev-lua/dkjson-2.5-r100[${LUA_USEDEP}]
- >=dev-lua/say-1.3_p1-r100[${LUA_USEDEP}]
- >=dev-lua/luassert-1.8.0-r100[${LUA_USEDEP}]
- >=dev-lua/lua-term-0.7-r100[${LUA_USEDEP}]
- >=dev-lua/penlight-1.7.0-r100[${LUA_USEDEP}]
- >=dev-lua/mediator_lua-1.1.2_p0-r100[${LUA_USEDEP}]
+ dev-lua/lua_cliargs[${LUA_USEDEP}]
+ dev-lua/luafilesystem[${LUA_USEDEP}]
+ dev-lua/luasystem[${LUA_USEDEP}]
+ dev-lua/dkjson[${LUA_USEDEP}]
+ dev-lua/say[${LUA_USEDEP}]
+ dev-lua/luassert[${LUA_USEDEP}]
+ dev-lua/lua-term[${LUA_USEDEP}]
+ dev-lua/penlight[${LUA_USEDEP}]
+ dev-lua/mediator_lua[${LUA_USEDEP}]
${LUA_DEPS}
"
@@ -36,7 +36,7 @@ DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
test? (
- >=dev-lua/busted-2.0.0-r100
+ dev-lua/busted
${RDEPEND}
)
"