summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:22:20 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:41 +0100
commitae63712a9371e4aeca3ec037096c724711cacb58 (patch)
treea11284d3d670cdf3de5944455bac5aa05b5cbf8a /dev-lua/lua-zlib
parentdev-lua/lua-zlib: update EAPI 7 -> 8 (diff)
downloadgentoo-ae63712a9371e4aeca3ec037096c724711cacb58.tar.gz
gentoo-ae63712a9371e4aeca3ec037096c724711cacb58.tar.bz2
gentoo-ae63712a9371e4aeca3ec037096c724711cacb58.zip
dev-lua/lua-zlib: drop 1.2-r100
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/lua-zlib')
-rw-r--r--dev-lua/lua-zlib/lua-zlib-1.2-r100.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-lua/lua-zlib/lua-zlib-1.2-r100.ebuild b/dev-lua/lua-zlib/lua-zlib-1.2-r100.ebuild
deleted file mode 100644
index ae3efd99edef..000000000000
--- a/dev-lua/lua-zlib/lua-zlib-1.2-r100.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit cmake lua
-
-DESCRIPTION="Simple streaming interface to zlib for Lua"
-HOMEPAGE="https://github.com/brimworks/lua-zlib"
-SRC_URI="https://github.com/brimworks/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-RDEPEND="
- sys-libs/zlib
- ${LUA_DEPS}
-
-"
-DEPEND="${RDEPEND}"
-
-lua_src_configure() {
- local mycmakeargs=(
- -DINSTALL_CMOD="$(lua_get_cmod_dir)"
- -DUSE_LUA_VERSION="$(lua_get_version)"
- )
-
- if [[ ${ELUA} == luajit ]]; then
- mycmakeargs+=( -DUSE_LUAJIT="ON" )
- fi
-
- cmake_src_configure
-}
-
-src_configure() {
- lua_foreach_impl lua_src_configure
-}
-
-src_compile() {
- lua_foreach_impl cmake_src_compile
-}
-
-src_install() {
- lua_foreach_impl cmake_src_install
-}