summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-11-04 21:58:25 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-11-04 21:58:54 +0100
commit0cb02ba655c0c415dd05ca5b0c93ee13174e709d (patch)
treecb6811b15be37dab208e5732d9aaf8473daf2d6a /dev-lua/luadbi
parentx11-misc/arandr: add missing dep (diff)
downloadgentoo-0cb02ba655c0c415dd05ca5b0c93ee13174e709d.tar.gz
gentoo-0cb02ba655c0c415dd05ca5b0c93ee13174e709d.tar.bz2
gentoo-0cb02ba655c0c415dd05ca5b0c93ee13174e709d.zip
dev-lua/luadbi: fix runtime
Closes: https://bugs.gentoo.org/820431 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/luadbi')
-rw-r--r--dev-lua/luadbi/luadbi-0.7.2-r103.ebuild (renamed from dev-lua/luadbi/luadbi-0.7.2-r102.ebuild)12
1 files changed, 12 insertions, 0 deletions
diff --git a/dev-lua/luadbi/luadbi-0.7.2-r102.ebuild b/dev-lua/luadbi/luadbi-0.7.2-r103.ebuild
index a10d25b72e03..0f05380ff39f 100644
--- a/dev-lua/luadbi/luadbi-0.7.2-r102.ebuild
+++ b/dev-lua/luadbi/luadbi-0.7.2-r103.ebuild
@@ -45,9 +45,13 @@ src_prepare() {
# Respect users CFLAGS
sed -e 's/-g //' -e 's/-O2 //g' -i Makefile || die
+
+ lua_copy_sources
}
lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
tc-export AR CC
local myemakeargs=(
@@ -57,6 +61,8 @@ lua_src_compile() {
use mysql && emake ${myemakeargs} MYSQL_INC="-I$(mariadb_config --libs)" mysql
use postgres && emake ${myemakeargs} PSQL_INC="-I$(pg_config --libdir)" psql
use sqlite emake ${myemakeargs} SQLITE3_INC="-I/usr/include" sqlite
+
+ die
}
src_compile() {
@@ -64,7 +70,9 @@ src_compile() {
}
lua_src_test() {
+ pushd "${BUILD_DIR}" || die
cd "${S}"/tests && ${ELUA} run_tests.lua || die
+ die
}
src_test() {
@@ -72,6 +80,8 @@ src_test() {
}
lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
local myemakeargs=(
DESTDIR="${ED}"
LUA_CDIR="$(lua_get_cmod_dir)"
@@ -82,6 +92,8 @@ lua_src_install() {
use mysql && emake ${myemakeargs[@]} install_mysql
use postgres && emake ${myemakeargs[@]} install_psql
use sqlite && emake ${myemakeargs[@]} install_sqlite3
+
+ die
}
src_install() {