summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-03-19 16:11:07 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-03-19 16:21:22 +0100
commit56fc18f53e3551ac0a46b8f344de11cd20b06da3 (patch)
tree5b2a97ef3ac10ecbe6d3303f92733722345a7740 /dev-lua
parentdev-lua/readline: initial import (diff)
downloadgentoo-56fc18f53e3551ac0a46b8f344de11cd20b06da3.tar.gz
gentoo-56fc18f53e3551ac0a46b8f344de11cd20b06da3.tar.bz2
gentoo-56fc18f53e3551ac0a46b8f344de11cd20b06da3.zip
dev-lua/lua-unbound: initial import
This is a needed dep for upcoming prosody-0.12 release. Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lua-unbound/Manifest1
-rw-r--r--dev-lua/lua-unbound/lua-unbound-1.0.0.ebuild68
-rw-r--r--dev-lua/lua-unbound/metadata.xml8
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-lua/lua-unbound/Manifest b/dev-lua/lua-unbound/Manifest
new file mode 100644
index 000000000000..bae911379a0d
--- /dev/null
+++ b/dev-lua/lua-unbound/Manifest
@@ -0,0 +1 @@
+DIST luaunbound-1.0.0.tar.gz 6366 BLAKE2B 7e5937e0109cb7222f982a62b7934ca272be9003810edee0d58684809928514441aeee22c83cbc3a8e309e9ee010f1d4afea50123647ad6eee387a556878f654 SHA512 9fab77481e7c84409d9ceb79156d06cb9ac2b2d7df53349e0f1b6c118022c9b1c22481e9413efedda41cc9acb1640d3d30cc4e0f9b7ed7fd6ed2511192a69d3c
diff --git a/dev-lua/lua-unbound/lua-unbound-1.0.0.ebuild b/dev-lua/lua-unbound/lua-unbound-1.0.0.ebuild
new file mode 100644
index 000000000000..1a400f07f939
--- /dev/null
+++ b/dev-lua/lua-unbound/lua-unbound-1.0.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+MY_PN="${PN/-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="A simple interface to the readline and history libraries"
+HOMEPAGE="https://pjb.com.au/comp/lua/readline.html"
+SRC_URI="https://code.zash.se/dl/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="net-dns/unbound"
+DEPEND="${RDEPEND}"
+
+DOCS=( "README.markdown" )
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS} -fPIC $(lua_get_CFLAGS)"
+ LD="$(tc-getCC)"
+ LDFLAGS="${LDFLAGS} -shared"
+ )
+
+ emake "${myemakeargs[@]}"
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ DESTDIR="${ED}"
+ LUA_LIBDIR="$(lua_get_cmod_dir)"
+ )
+
+ emake "${myemakeargs[@]}" install
+ einstalldocs
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}
diff --git a/dev-lua/lua-unbound/metadata.xml b/dev-lua/lua-unbound/metadata.xml
new file mode 100644
index 000000000000..c07e13d4a6bd
--- /dev/null
+++ b/dev-lua/lua-unbound/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+</pkgmetadata>