summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 13:44:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-01 14:24:44 +0200
commit13cad5f6060ab60c08e7b46ac444c58d940ec99c (patch)
treeeb21aa7bff4e9926d0be16681e8dc18238311413 /dev-ml/atdgen/atdgen-1.10.0.ebuild
parentdev-ml/atd: Initial import. Ebuild by me. (diff)
downloadgentoo-13cad5f6060ab60c08e7b46ac444c58d940ec99c.tar.gz
gentoo-13cad5f6060ab60c08e7b46ac444c58d940ec99c.tar.bz2
gentoo-13cad5f6060ab60c08e7b46ac444c58d940ec99c.zip
dev-ml/atdgen: Initial import. Ebuild by me.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/atdgen/atdgen-1.10.0.ebuild')
-rw-r--r--dev-ml/atdgen/atdgen-1.10.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/atdgen/atdgen-1.10.0.ebuild b/dev-ml/atdgen/atdgen-1.10.0.ebuild
new file mode 100644
index 000000000000..99f038f67b65
--- /dev/null
+++ b/dev-ml/atdgen/atdgen-1.10.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="Generates optimized boilerplate OCaml code for JSON and Biniou IO from type definitions"
+HOMEPAGE="https://github.com/mjambon/atdgen"
+SRC_URI="https://github.com/mjambon/atdgen/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/atd:=[ocamlopt?]
+ dev-ml/biniou:=[ocamlopt?]
+ dev-ml/yojson:=
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake -j1 all
+ use ocamlopt && emake opt
+}
+
+src_install() {
+ dodir /usr/bin
+ PREFIX="${ED}/usr" findlib_src_install
+ dodoc README.md
+}