summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Brewer <tomboy64@sina.cn>2016-01-06 22:37:56 +0100
committerMatthew Brewer <tomboy64@sina.cn>2016-01-06 22:37:56 +0100
commitad6f3b6903bff4f80c3b321f9423cddd1d896135 (patch)
tree3b1ae40a3ba72c64a881870773e8d2dc0d2fae9d /dev-ml/mirage-profile
parentx11-misc/i3status: syntax sugar (diff)
downloadgentoo-ad6f3b6903bff4f80c3b321f9423cddd1d896135.tar.gz
gentoo-ad6f3b6903bff4f80c3b321f9423cddd1d896135.tar.bz2
gentoo-ad6f3b6903bff4f80c3b321f9423cddd1d896135.zip
dev-ml/mirage-profile: version bump to 0.6 and 0.6.1
Diffstat (limited to 'dev-ml/mirage-profile')
-rw-r--r--dev-ml/mirage-profile/Manifest2
-rw-r--r--dev-ml/mirage-profile/mirage-profile-0.6.1.ebuild32
-rw-r--r--dev-ml/mirage-profile/mirage-profile-0.6.ebuild32
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-ml/mirage-profile/Manifest b/dev-ml/mirage-profile/Manifest
index 0488c3222b33..244345a29e8b 100644
--- a/dev-ml/mirage-profile/Manifest
+++ b/dev-ml/mirage-profile/Manifest
@@ -1 +1,3 @@
DIST mirage-profile-0.5.tar.gz 55122 SHA256 ae8a6dc953f4eddd4ce61aef36552036c1814732dd3d50e02ea2994d137b8c85 SHA512 a82c4f2c42a1b950726069ce6d64f403438847bb4f5023b022b20bd42dde29d679fed358c67c3eec3ad6e5c8253453b6d1008e5e52b37a373a62263a99aa35c2 WHIRLPOOL b054c5c19102f73f9b47d796b10f4bb3e83e3de336b936ced23623d9f1cb03899cf5434ce9bd91ebe68226f3707cbbcfcfb7bfce7585af51fcdcfe383e04eecc
+DIST mirage-profile-0.6.1.tar.gz 55308 SHA256 870d536c8db32f160108155a04565561fcb481669121f623a6a599fac1eb419b SHA512 99955586d82f85fc31ddea15123e681cc1c8e11bbc489bfae0e8ee3576c15b63c5f170ba8042196d2501fd663d2367cb90abdffd62c3dda55fbdf69c639dd480 WHIRLPOOL fd38e26ba835651178ed000b5d144206d4c31bfbfe5fab7ce707f35038b04df4d680a408f89cfa2db044f762ec0858bed14c580d23d7200a97ebd50f572ef3e3
+DIST mirage-profile-0.6.tar.gz 55287 SHA256 ecb2d7591eafa1d1f0cd751f2f3b88a96d308d48db0fdce025461d558ebcfe98 SHA512 65e756026a3b1f2c26763c5f645458c7a26aef3da4670e71da9deff156848f0db5cc56374db8984fe2c0ead2b50ba77d39535de0a6ee7a564523d50b487d6690 WHIRLPOOL a023d04b2ff1d96b04842f183a760af0df8c52ec162295d3f9b2d92e7258412c0acd975bd73c7cb7fb00a441ba24cb657bfb0a57e9dd913cef561592de2c8bf0
diff --git a/dev-ml/mirage-profile/mirage-profile-0.6.1.ebuild b/dev-ml/mirage-profile/mirage-profile-0.6.1.ebuild
new file mode 100644
index 000000000000..38b806f213e9
--- /dev/null
+++ b/dev-ml/mirage-profile/mirage-profile-0.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Collect profiling information"
+HOMEPAGE="https://github.com/mirage/mirage-profile https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+# https://github.com/mirage/mirage-profile/issues/11
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4:=
+ dev-ml/io-page:=
+ dev-ml/lwt:=
+ dev-ml/ocaml-cstruct:=[camlp4(-)]
+ dev-ml/ocplib-endian:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( README.md )
diff --git a/dev-ml/mirage-profile/mirage-profile-0.6.ebuild b/dev-ml/mirage-profile/mirage-profile-0.6.ebuild
new file mode 100644
index 000000000000..38b806f213e9
--- /dev/null
+++ b/dev-ml/mirage-profile/mirage-profile-0.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Collect profiling information"
+HOMEPAGE="https://github.com/mirage/mirage-profile https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+# https://github.com/mirage/mirage-profile/issues/11
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4:=
+ dev-ml/io-page:=
+ dev-ml/lwt:=
+ dev-ml/ocaml-cstruct:=[camlp4(-)]
+ dev-ml/ocplib-endian:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( README.md )