summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-08 16:58:27 +0000
committerSam James <sam@gentoo.org>2021-02-08 17:20:53 +0000
commit2162c9a1fbe89fb2af98cb6420e3d4fc08d3167b (patch)
treef4d31214316b0e6804d259df3fc5ec0b8eeb51d1 /dev-ml/opam-core
parentdev-ml/alcotest: bump to 1.2.3 (diff)
downloadgentoo-2162c9a1fbe89fb2af98cb6420e3d4fc08d3167b.tar.gz
gentoo-2162c9a1fbe89fb2af98cb6420e3d4fc08d3167b.tar.bz2
gentoo-2162c9a1fbe89fb2af98cb6420e3d4fc08d3167b.zip
dev-ml/opam-core: bump to 2.0.8
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/opam-core')
-rw-r--r--dev-ml/opam-core/Manifest1
-rw-r--r--dev-ml/opam-core/opam-core-2.0.8.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/opam-core/Manifest b/dev-ml/opam-core/Manifest
index db4db56c08eb..39fe274747df 100644
--- a/dev-ml/opam-core/Manifest
+++ b/dev-ml/opam-core/Manifest
@@ -1 +1,2 @@
DIST opam-2.0.7.tar.gz 636708 BLAKE2B 2824a5c53f4103c267f99ae10f55df740b3afcc033321e888133817c0e53c4a8fc31738338df3d6d9ff8755987e85ade4a4726be98f77b06b81ffc1476d02c3d SHA512 2ade3998a94333a5a838b55e229ab0c707e678481cae892980b986fb86f39163070a9b7d3e0e87879cd57b91a33bf6a3e15f3786c3510a635e59383782218f1d
+DIST opam-2.0.8.tar.gz 643221 BLAKE2B 66510a18285f315fe95665e8ba2f334dd44211c716543cdc25f2951a7dfe537f115981046e5963fd08deea4c76f5672fa7cf8e7af2274a713a3165bdd0bac8c2 SHA512 14737dc994be2c54dfeaf2658d3713178033e1bc2b4b845a58b4bfc118bbbf12b502924add0ae32b4b2b6c1944462e5ee7143df3de362d9ee39573249d013bc9
diff --git a/dev-ml/opam-core/opam-core-2.0.8.ebuild b/dev-ml/opam-core/opam-core-2.0.8.ebuild
new file mode 100644
index 000000000000..9d6e32634c0b
--- /dev/null
+++ b/dev-ml/opam-core/opam-core-2.0.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+inherit opam
+
+DESCRIPTION="Core libraries for opam"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-ml/ocamlgraph:=
+ dev-ml/re:=
+ dev-ml/opam-file-format:=
+ dev-ml/cmdliner:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo"
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9)))
+ (release
+ (flags (:standard -warn-error -3-9))))
+ EOF
+}
+
+src_compile() {
+ emake -j1 opam-installer
+ emake -j1 ${PN}.install
+}