summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-17 21:18:52 +0000
committerSam James <sam@gentoo.org>2020-10-17 21:32:23 +0000
commit9a7a91c09387f59121295446510e1bdf2a04ddb2 (patch)
treef33094673be29567cf0875b636c5ca40d35f4b2a /dev-ml/pcre-ocaml
parentsci-visualization/gr: Always depend on libX11 and libXt (diff)
downloadgentoo-9a7a91c09387f59121295446510e1bdf2a04ddb2.tar.gz
gentoo-9a7a91c09387f59121295446510e1bdf2a04ddb2.tar.bz2
gentoo-9a7a91c09387f59121295446510e1bdf2a04ddb2.zip
dev-ml/pcre-ocaml: restore 7.2.3
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/pcre-ocaml')
-rw-r--r--dev-ml/pcre-ocaml/Manifest1
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-7.2.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/pcre-ocaml/Manifest b/dev-ml/pcre-ocaml/Manifest
index 8fcd3c5487cb..583d603af7c7 100644
--- a/dev-ml/pcre-ocaml/Manifest
+++ b/dev-ml/pcre-ocaml/Manifest
@@ -1,2 +1,3 @@
+DIST pcre-ocaml-7.2.3.tar.gz 88307 BLAKE2B 1024a0d7a490fb31927f67af4c9a5e90c8d3788b3998a8af1ecaba9d6d12d1a1be91dcb2bdc1c49e6e81f0909d1dd9b6bc200f908c68427650985491f35685c9 SHA512 3df4bdbbed5e1ecf4bdf15fc461f2ea65e1556af9c1683e194c8824e21da5274dd80c22c1f6676fca203305ec4244d47e09f0ef8c601bfa95f7237bb07c1ee65
DIST pcre-ocaml-7.3.3.tbz 38412 BLAKE2B 3c9538f5fc8bc6dea0c6ceda3a2b30a48302943d53a83a4876c31dbe600752ac68498a4db9546698424b34bbd55c6c3254d47148233a845376887c30dc6fd429 SHA512 569e323dea83f33212a2aa9482e55f7491c8f83382fad13dfaf9fe624307ca261baf255db7c5837e1c6b5c64445daf05b64b9929cbd6d311d06278826bb788e3
DIST pcre-ocaml-7.4.6.tbz 41027 BLAKE2B 1faecd96cb6f7af248e8ace7409a49131f5c654320f8ac432fd4aff602d0c4187733419e9cc73ca52cf0a3e5b725afa9357fe9ec191bf1ca42d4dc47a36e45b7 SHA512 a356c78dc19d3b3741d1fa0277c4fb0cb545f12499165526fae80a0ff8a7b1f1e6e5e916b16f8336bcec3661de811686b814fe4afc677965fec7a63d4fc53b1f
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-7.2.3.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-7.2.3.ebuild
new file mode 100644
index 000000000000..a35bab372f29
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-7.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pcre-ocaml/ https://github.com/mmottl/pcre-ocaml"
+SRC_URI="https://github.com/mmottl/pcre-ocaml/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+IUSE="examples"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND=">=dev-libs/libpcre-4.5
+ >=dev-lang/ocaml-4:="
+DEPEND="${RDEPEND}"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}