summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 19:20:52 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commitf39173d0f359a19dbd6eeca91a06d51413dc2ec4 (patch)
tree2bc08d873a6b92b96542964b74a81e6586a8d95d /dev-ml/ppx_expect
parentdev-ml/ppx_variants_conv: initial import; ebuild by me (diff)
downloadgentoo-f39173d0f359a19dbd6eeca91a06d51413dc2ec4.tar.gz
gentoo-f39173d0f359a19dbd6eeca91a06d51413dc2ec4.tar.bz2
gentoo-f39173d0f359a19dbd6eeca91a06d51413dc2ec4.zip
dev-ml/ppx_expect: initial import; ebuild by me
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_expect')
-rw-r--r--dev-ml/ppx_expect/Manifest1
-rw-r--r--dev-ml/ppx_expect/metadata.xml8
-rw-r--r--dev-ml/ppx_expect/ppx_expect-113.24.00.ebuild53
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-ml/ppx_expect/Manifest b/dev-ml/ppx_expect/Manifest
new file mode 100644
index 000000000000..2737f4d05215
--- /dev/null
+++ b/dev-ml/ppx_expect/Manifest
@@ -0,0 +1 @@
+DIST ppx_expect-113.24.00.tar.gz 69986 SHA256 c06ab7c70219da64c0d334ab91aad9f58d52b6e9303ab5669f5674e0439f3ad9 SHA512 194384db2cd8dc2994cbf7b4d8f0480d11e8c4b23fee3e893afcfdbca67ba931c80b870b48de9e60ee442401f6661e2dbc599d1a33705dc00dcf991c1a71032a WHIRLPOOL 17d8725aa40a12cf5f9f41d4bed720303d601f1becec77685ba20593d23f6a8b71c1c2ff289938196b65ce75d16661011780dc246614902b52d6da87a41b3d8c
diff --git a/dev-ml/ppx_expect/metadata.xml b/dev-ml/ppx_expect/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/ppx_expect/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ppx_expect/ppx_expect-113.24.00.ebuild b/dev-ml/ppx_expect/ppx_expect-113.24.00.ebuild
new file mode 100644
index 000000000000..c605caa63581
--- /dev/null
+++ b/dev-ml/ppx_expect/ppx_expect-113.24.00.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Cram like framework for OCaml"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/ppx_tools:=
+ dev-ml/fieldslib:=
+ dev-ml/ppx_assert:=
+ dev-ml/ppx_compare:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_custom_printf:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_fields_conv:=
+ dev-ml/ppx_inline_test:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ppx_sexp_value:=
+ dev-ml/ppx_variants_conv:=
+ dev-ml/ocaml-re:=
+ dev-ml/sexplib:=
+ dev-ml/variantslib:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}