summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-07 23:50:43 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-08 00:26:32 +0100
commit177260cc0353a1f30eaf54cad31e5f245fcd5a52 (patch)
tree0ddc27dada40efccf479895dffc2630d065583de /dev-ml/zed
parentdev-ml/mew_vi: new package; add version 0.5.0 (diff)
downloadgentoo-177260cc0353a1f30eaf54cad31e5f245fcd5a52.tar.gz
gentoo-177260cc0353a1f30eaf54cad31e5f245fcd5a52.tar.bz2
gentoo-177260cc0353a1f30eaf54cad31e5f245fcd5a52.zip
dev-ml/zed: new package; add version 3.1.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/zed')
-rw-r--r--dev-ml/zed/Manifest1
-rw-r--r--dev-ml/zed/metadata.xml22
-rw-r--r--dev-ml/zed/zed-3.1.0.ebuild22
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/zed/Manifest b/dev-ml/zed/Manifest
new file mode 100644
index 000000000000..eaad68c3bbb2
--- /dev/null
+++ b/dev-ml/zed/Manifest
@@ -0,0 +1 @@
+DIST zed-3.1.0.tar.gz 45535 BLAKE2B 8c8898f01add91807fa282baae1c5ee34e77c5234e87e4c79c17a9f55756d3b4c2af5f0b01deb9414a657f63ea6cf6db44af7249adb0f2b147e923b4112a7dd7 SHA512 d4457af15f970adb7b1ed543017e590fa0ecc47171d6dd520a1397f21ce0219caa30a9db7bedb76c0602d4f6d0f0684012cc33feafe18b848d3261a460dea10a
diff --git a/dev-ml/zed/metadata.xml b/dev-ml/zed/metadata.xml
new file mode 100644
index 000000000000..b2be3f06ce46
--- /dev/null
+++ b/dev-ml/zed/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ Zed is an abstract engine for text edition. It can be used to write text
+ editors, edition widgets, readlines, ... Zed uses Camomile to fully
+ support the Unicode specification, and implements an UTF-8 encoded string
+ type with validation, and a rope datastructure to achieve efficient
+ operations on large Unicode buffers. Zed also features a regular expression
+ search on ropes. To support efficient text edition capabilities,
+ Zed provides macro recording and cursor management facilities.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/ocaml-community/zed/issues/</bugs-to>
+ <remote-id type="github">ocaml-community/zed</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/zed/zed-3.1.0.ebuild b/dev-ml/zed/zed-3.1.0.ebuild
new file mode 100644
index 000000000000..64634262c7c0
--- /dev/null
+++ b/dev-ml/zed/zed-3.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Abstract engine for text edition in OCaml"
+HOMEPAGE="https://github.com/ocaml-community/zed"
+SRC_URI="https://github.com/ocaml-community/zed/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/camomile:=
+ dev-ml/charinfo_width:=
+ dev-ml/react:=
+"
+DEPEND="${RDEPEND}"