summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-08 14:26:04 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-08 14:36:08 +0100
commit5f7953f5a8ae55454c9f5675d8e4776206e80211 (patch)
treea02c12b2f0804acbbd145e2b0c1afb10dfa277f5 /dev-ml
parentdev-ml/pa_sexp_conv: initial import; ebuild by me; compat for packages needed... (diff)
downloadgentoo-5f7953f5a8ae55454c9f5675d8e4776206e80211.tar.gz
gentoo-5f7953f5a8ae55454c9f5675d8e4776206e80211.tar.bz2
gentoo-5f7953f5a8ae55454c9f5675d8e4776206e80211.zip
dev-ml/ocaml-uri: port to pa_sexp_conv and avoid requiring old sexplib
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-uri/files/sexpl.patch42
-rw-r--r--dev-ml/ocaml-uri/ocaml-uri-1.9.1-r1.ebuild3
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-ml/ocaml-uri/files/sexpl.patch b/dev-ml/ocaml-uri/files/sexpl.patch
new file mode 100644
index 000000000000..85008d11537d
--- /dev/null
+++ b/dev-ml/ocaml-uri/files/sexpl.patch
@@ -0,0 +1,42 @@
+Index: ocaml-uri-1.9.1/_tags
+===================================================================
+--- ocaml-uri-1.9.1.orig/_tags
++++ ocaml-uri-1.9.1/_tags
+@@ -22,7 +22,7 @@ true: annot, bin_annot
+ "lib/services_full.cmxs": use_services_full
+ <lib/*.ml{,i,y}>: package(re.posix)
+ <lib/*.ml{,i,y}>: package(sexplib)
+-<lib/*.ml{,i,y}>: package(sexplib.syntax)
++<lib/*.ml{,i,y}>: package(pa_sexp_conv.syntax)
+ <lib/*.ml{,i,y}>: package(stringext)
+ <lib/*.ml{,i,y}>: use_uri
+ # Library uri_top
+@@ -32,13 +32,13 @@ true: annot, bin_annot
+ <lib_test/test_runner.{native,byte}>: package(oUnit)
+ <lib_test/test_runner.{native,byte}>: package(re.posix)
+ <lib_test/test_runner.{native,byte}>: package(sexplib)
+-<lib_test/test_runner.{native,byte}>: package(sexplib.syntax)
++<lib_test/test_runner.{native,byte}>: package(pa_sexp_conv)
+ <lib_test/test_runner.{native,byte}>: package(stringext)
+ <lib_test/test_runner.{native,byte}>: use_uri
+ <lib_test/*.ml{,i,y}>: package(oUnit)
+ <lib_test/*.ml{,i,y}>: package(re.posix)
+ <lib_test/*.ml{,i,y}>: package(sexplib)
+-<lib_test/*.ml{,i,y}>: package(sexplib.syntax)
++<lib_test/*.ml{,i,y}>: package(pa_sexp_conv)
+ <lib_test/*.ml{,i,y}>: package(stringext)
+ <lib_test/*.ml{,i,y}>: use_uri
+ <lib_test/test_runner.{native,byte}>: custom
+Index: ocaml-uri-1.9.1/setup.ml
+===================================================================
+--- ocaml-uri-1.9.1.orig/setup.ml
++++ ocaml-uri-1.9.1/setup.ml
+@@ -6964,7 +6964,7 @@ let setup_t =
+ [
+ FindlibPackage ("re.posix", None);
+ FindlibPackage ("stringext", None);
+- FindlibPackage ("sexplib.syntax", None);
++ FindlibPackage ("pa_sexp_conv.syntax", None);
+ FindlibPackage ("sexplib", None)
+ ];
+ bs_build_tools = [ExternalTool "ocamlbuild"];
diff --git a/dev-ml/ocaml-uri/ocaml-uri-1.9.1-r1.ebuild b/dev-ml/ocaml-uri/ocaml-uri-1.9.1-r1.ebuild
index 52341e8abff8..62fa77aebb81 100644
--- a/dev-ml/ocaml-uri/ocaml-uri-1.9.1-r1.ebuild
+++ b/dev-ml/ocaml-uri/ocaml-uri-1.9.1-r1.ebuild
@@ -20,7 +20,7 @@ IUSE="allservices"
RDEPEND="
dev-ml/ocaml-re:=
>=dev-ml/sexplib-109.53.00:=
- <dev-ml/sexplib-113.01.00
+ dev-ml/pa_sexp_conv:=
dev-ml/stringext:=
dev-ml/type-conv:=
"
@@ -28,6 +28,7 @@ DEPEND="
test? ( >=dev-ml/ounit-1.0.2 )
${RDEPEND}
"
+PATCHES=( "${FILESDIR}/sexpl.patch" )
src_configure() {
oasis_configure_opts="