summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-04 17:19:12 +0000
committerSam James <sam@gentoo.org>2021-01-04 17:27:04 +0000
commite348d79b597d3e148a816af879057c1a5a594623 (patch)
tree7ccca68c4317e0011836c35e0fd7b184330dbff6 /dev-ml
parentdev-ml/yojson: bump to 1.7.0 (diff)
downloadgentoo-e348d79b597d3e148a816af879057c1a5a594623.tar.gz
gentoo-e348d79b597d3e148a816af879057c1a5a594623.tar.bz2
gentoo-e348d79b597d3e148a816af879057c1a5a594623.zip
dev-ml/yojson: dependency fixes
* We need +/-ocamlopt aligned on dependencies * cppo is BDEPEND because it's a preprocessor Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/yojson/yojson-1.7.0.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-ml/yojson/yojson-1.7.0.ebuild b/dev-ml/yojson/yojson-1.7.0.ebuild
index fbfcfb4f3d5c..6b433e0f94ae 100644
--- a/dev-ml/yojson/yojson-1.7.0.ebuild
+++ b/dev-ml/yojson/yojson-1.7.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,13 +14,13 @@ SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE="examples +ocamlopt"
-RDEPEND=">=dev-lang/ocaml-4.02.3:=[ocamlopt]
- dev-ml/easy-format:=[ocamlopt]
- >=dev-ml/biniou-1.2:=[ocamlopt]
-"
-DEPEND="${RDEPEND}
- >=dev-ml/cppo-1.6.1
+RDEPEND="
+ >=dev-lang/ocaml-4.02.3:=[ocamlopt=]
+ dev-ml/easy-format:=[ocamlopt=]
+ >=dev-ml/biniou-1.2:=[ocamlopt=]
"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/cppo-1.6.1"
src_install() {
dune_src_install