summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Class-DBI
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Class-DBI')
-rw-r--r--dev-perl/Class-DBI/Class-DBI-3.0.17-r1.ebuild33
-rw-r--r--dev-perl/Class-DBI/Manifest1
-rw-r--r--dev-perl/Class-DBI/metadata.xml26
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-perl/Class-DBI/Class-DBI-3.0.17-r1.ebuild b/dev-perl/Class-DBI/Class-DBI-3.0.17-r1.ebuild
new file mode 100644
index 000000000000..f7dcc2cd9d61
--- /dev/null
+++ b/dev-perl/Class-DBI/Class-DBI-3.0.17-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=TMTM
+MY_P=${PN}-v${PV}
+S=${WORKDIR}/${MY_P}
+
+inherit perl-module
+
+DESCRIPTION="Simple Database Abstraction"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ppc64 x86 ~x86-solaris"
+IUSE=""
+
+# Tests aren't possible since they require interaction with the DB's
+
+RDEPEND=">=dev-perl/Class-Data-Inheritable-0.02
+ >=dev-perl/Class-Accessor-0.18
+ >=dev-perl/Class-Trigger-0.07
+ virtual/perl-File-Temp
+ virtual/perl-Storable
+ virtual/perl-Test-Simple
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Clone
+ >=dev-perl/Ima-DBI-0.33
+ virtual/perl-version
+ >=dev-perl/UNIVERSAL-moniker-0.06"
+DEPEND="${RDEPEND}"
diff --git a/dev-perl/Class-DBI/Manifest b/dev-perl/Class-DBI/Manifest
new file mode 100644
index 000000000000..a3dcae813d04
--- /dev/null
+++ b/dev-perl/Class-DBI/Manifest
@@ -0,0 +1 @@
+DIST Class-DBI-v3.0.17.tar.gz 105416 SHA256 541354fe361c56850cb11261f6ca089a14573fa764792447444ff736ae626206 SHA512 006bc6ca754d24d9cb3791fa99128df597be1f96cb62c309a0f37f169e02e2baec6aa7e6395ddea8202df11488a9db52fa817d8fff7f925097769d70356d1fe7 WHIRLPOOL 63dd1b49c272f44aa9b2d0626aac86b621b38b503892d09006050b25cf4803d92ef446cbd26f56f1350a68e3220a44ce27fb4660c7d865d87f5087695932141b
diff --git a/dev-perl/Class-DBI/metadata.xml b/dev-perl/Class-DBI/metadata.xml
new file mode 100644
index 000000000000..240d2456d575
--- /dev/null
+++ b/dev-perl/Class-DBI/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Class-DBI</remote-id>
+ <remote-id type="cpan-module">Class::DBI</remote-id>
+ <remote-id type="cpan-module">Class::DBI::Attribute</remote-id>
+ <remote-id type="cpan-module">Class::DBI::Cascade::Delete</remote-id>
+ <remote-id type="cpan-module">Class::DBI::Cascade::Fail</remote-id>
+ <remote-id type="cpan-module">Class::DBI::Cascade::None</remote-id>
+ <remote-id type="cpan-module">Class::DBI::Column</remote-id>
+ <remote-id type="cpan-module">Class::DBI::ColumnGrouper</remote-id>
+ <remote-id type="cpan-module">Class::DBI::Iterator</remote-id>
+ <remote-id type="cpan-module">Class::DBI::Query</remote-id>
+ <remote-id type="cpan-module">Class::DBI::Query::Base</remote-id>
+ <remote-id type="cpan-module">Class::DBI::Relationship</remote-id>
+ <remote-id type="cpan-module">Class::DBI::Relationship::HasA</remote-id>
+ <remote-id type="cpan-module">Class::DBI::Relationship::HasMany</remote-id>
+ <remote-id type="cpan-module">Class::DBI::Relationship::MightHave</remote-id>
+ <remote-id type="cpan-module">Class::DBI::SQL::Transformer</remote-id>
+ <remote-id type="cpan-module">Class::DBI::Search::Basic</remote-id>
+ <remote-id type="cpan-module">Class::DBI::Test::SQLite</remote-id>
+ <remote-id type="cpan-module">Class::DBI::__::Base</remote-id>
+ </upstream>
+</pkgmetadata>