summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-11 11:38:00 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-11 16:45:53 +1300
commitfb2e7dffd4373971446f21b89164eac654f59c4d (patch)
tree6e5a578ad9e8843f7efd2f9f8b4b4643c1d49a81 /dev-perl/Date-Manip
parentdev-perl/Date-Extract: Bump to 0.50.0 (diff)
downloadgentoo-fb2e7dffd4373971446f21b89164eac654f59c4d.tar.gz
gentoo-fb2e7dffd4373971446f21b89164eac654f59c4d.tar.bz2
gentoo-fb2e7dffd4373971446f21b89164eac654f59c4d.zip
dev-perl/Date-Manip: Bump to version 6.560.0
Upstream: - Fix bug where $::TZ was unused - Fixed bug in parsing recurrences - Methods that return derived objects now more-correctly use existing object. - Updated tzdata - 5.xx tests disabled by default - Fixed bug in parsing TZ abbreviations - Fixed bug in Date::Manip::Delta::cmp Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/Date-Manip')
-rw-r--r--dev-perl/Date-Manip/Date-Manip-6.560.0.ebuild41
-rw-r--r--dev-perl/Date-Manip/Manifest1
-rw-r--r--dev-perl/Date-Manip/files/Date-Manip-6.56-dirname-version.patch44
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-perl/Date-Manip/Date-Manip-6.560.0.ebuild b/dev-perl/Date-Manip/Date-Manip-6.560.0.ebuild
new file mode 100644
index 000000000000..2d40d91b4a6e
--- /dev/null
+++ b/dev-perl/Date-Manip/Date-Manip-6.560.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=SBECK
+DIST_VERSION=6.56
+
+inherit perl-module
+
+DESCRIPTION="Perl date manipulation routines"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="elibc_musl test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-${DIST_VERSION}-dirname-version.patch"
+)
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Data-Dumper
+ virtual/perl-Encode
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ virtual/perl-Storable
+ elibc_musl? ( sys-libs/timezone-data )
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.670.100
+ test? (
+ dev-perl/Test-Inter
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ perl_rm_files t/pod_coverage.t t/pod.t
+ perl-module_src_test
+}
diff --git a/dev-perl/Date-Manip/Manifest b/dev-perl/Date-Manip/Manifest
index 2329d7ddec30..c65648113393 100644
--- a/dev-perl/Date-Manip/Manifest
+++ b/dev-perl/Date-Manip/Manifest
@@ -1,2 +1,3 @@
DIST Date-Manip-6.51.tar.gz 1799860 SHA256 23bca630398d33ee16d6d8b285206dfdfa93739da771d30e40ed6a28b0c8db29 SHA512 96e0ef8374680a6adb3a064509d50a0e9288b14ce1e728b181e0f344ff85dfeb7b26ad4117fcfc35d3a6e4d6db3e97da242e2f6a11a88a11571a9b1f169f8e54 WHIRLPOOL e22746dcbd39e19412000c4cd20a09757c20c12c5407b7206eccac80942376e2d02d0b856380fe13956734208717db0497d8e2be89bcfd34744216223e0f2446
DIST Date-Manip-6.52.tar.gz 1833161 SHA256 3f7b31a0d9f47a111e1a128e708d4c1ee0f6815ead81737fc4de96438f61e511 SHA512 8a232e8fcc2c5abc1fb82c5096ae8a80b6a6c1d6ef94ca87cbdf15907dedfa64b41008149e0026e4898c96e649b1d69ca304fb529ea32253737e513b809afc6b WHIRLPOOL 8a44a26238799673fb132e73a7713f7ab0a6ee90ca3e416ae28f529507f0ffb0c7f45ad314fa3d2d6a57b39819ca516eda6272ff5815eb90c91c019f96bd86ec
+DIST Date-Manip-6.56.tar.gz 1829314 SHA256 acae07026b84d157f161d569b41026f4770e72872a5c7d70c295e2083a1ff5ec SHA512 1faf36ab2d96b5841ffd408b981818cb86ca12c327adbc2b29e8369ab63d9cd6a57b1cce232ad46333945d0be4b155761038df19da3f1a0a3f3b66d817c41337 WHIRLPOOL 83b4fddc154dbc9ecb0b29e19e40f41fdd364d9312e7f0c53ad835fbf0bb19bf5bc0c8918feef5b266ac4403b48c02ac133982b46ff7be140412df60afd8e5a8
diff --git a/dev-perl/Date-Manip/files/Date-Manip-6.56-dirname-version.patch b/dev-perl/Date-Manip/files/Date-Manip-6.56-dirname-version.patch
new file mode 100644
index 000000000000..128491b282b3
--- /dev/null
+++ b/dev-perl/Date-Manip/files/Date-Manip-6.56-dirname-version.patch
@@ -0,0 +1,44 @@
+From bddc157c9624a8a2a2c83efb6fe846292c9f4ca1 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Fri, 11 Nov 2016 10:48:50 +1300
+Subject: [PATCH] Don't inherit test version from directory name
+
+As per RT#118705, this regex relies on extracting the version
+from the directory name for comparison, which on Gentoo, gets
+the *parent* directory, and picks up the Gentoo normalized version
+instead of upstreams version in a child path.
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=118705
+---
+ t/obj.t | 14 ++------------
+ 1 file changed, 2 insertions(+), 12 deletions(-)
+
+diff --git a/t/obj.t b/t/obj.t
+index 8a26395..1691f46 100755
+--- a/t/obj.t
++++ b/t/obj.t
+@@ -5,19 +5,9 @@ $t = new Test::Inter 'object';
+ $testdir = '';
+ $testdir = $t->testdir();
+
+-use Cwd;
+-my $dir = getcwd;
+-$dir =~ /Date-Manip-([0-9.]+)/;
+-my $vers = $1;
+-
+-# Travis-CI renames the directory to just Date-Manip (no version) so this
+-# test cannot be done.
+-if (! defined $vers) {
+- $vers = DateManipVersion();
+-}
+-
+-$ENV{'TZ'} = 'America/Chicago';
+ use Date::Manip;
++my $vers = DateManipVersion();
++$ENV{'TZ'} = 'America/Chicago';
+ if (DateManipVersion() >= 6.00) {
+ $t->feature("DM6",1);
+ }
+--
+2.10.2
+