summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-21 21:09:00 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-21 21:38:00 +1300
commit4a7d8be51a40c1535d62abc8f122922de8e8334d (patch)
tree06dd314604cc1c3040d94dc70011808768ab489a /dev-perl/Festival-Client-Async
parentdev-perl/Feed-Find: Add tests (diff)
downloadgentoo-4a7d8be51a40c1535d62abc8f122922de8e8334d.tar.gz
gentoo-4a7d8be51a40c1535d62abc8f122922de8e8334d.tar.bz2
gentoo-4a7d8be51a40c1535d62abc8f122922de8e8334d.zip
dev-perl/Festival-Client-Async: EAPI6 + Tests
- EAPI6 - Basic compile tests - Document advanced testing Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Festival-Client-Async')
-rw-r--r--dev-perl/Festival-Client-Async/Festival-Client-Async-0.30.300-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Festival-Client-Async/Festival-Client-Async-0.30.300-r2.ebuild b/dev-perl/Festival-Client-Async/Festival-Client-Async-0.30.300-r2.ebuild
new file mode 100644
index 000000000000..6427667e2dbb
--- /dev/null
+++ b/dev-perl/Festival-Client-Async/Festival-Client-Async-0.30.300-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DJHD
+DIST_VERSION=0.0303
+inherit perl-module
+
+DESCRIPTION="Non-blocking interface to a Festival server"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE=""
+
+src_test() {
+ local MODULES=(
+ "Festival::Client::Async ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ ewarn "Comprehensive testing may require manual steps. For details, see:"
+ ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/Festival-Client-Async"
+ perl-module_src_test
+}